Bug 1792984

Summary: python-keystoneauth1 fails to create SRPM in Fedora
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-keystoneauth1Assignee: Thomas Oulevey <thomas.oulevey>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amoralej, apevec, cstratak, karlthered, mhroncok, openstack-sig, pabelanger, thomas.oulevey
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-20 16:10:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1750908, 1785415    

Description Miro Hrončok 2020-01-20 13:15:52 UTC
python-keystoneauth1 fails to create SRPM due to unescaped nested macros.

error: Cannot use %python if %__python wasn't redefined to something other than /usr/bin/python.
error: lua script failed: [string "<lua>"]:4: error expanding macro
error: /builddir/build/SPECS/python-keystoneauth1.spec: line 8: Macro %pyver_sitelib failed to expand


Possible fix is at https://src.fedoraproject.org/rpms/python-debtcollector/pull-request/3

Alternate fix is also described there.

This blocks the Python 3.9 rebuild.

Comment 1 Alfredo Moralejo 2020-01-20 16:08:39 UTC
fixed in https://src.fedoraproject.org/rpms/python-keystoneauth1/c/801824125f3bc801a82a18cf7ee0f3b7091a5e11?branch=master

Tested with python3.9 copr mock config.