Bug 1794336

Summary: vigra fails to build with gcc 10: internal compiler error: in nothrow_spec_p
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: vigraAssignee: Bruno Postle <bruno>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bruno, cstratak, mhroncok
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-28 08:17:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1794094    
Bug Blocks: 1750908, 1785415, 1792464    

Description Miro Hrončok 2020-01-23 10:33:11 UTC
vigra fails to build with gcc 10:


Event                            | Plugins
PLUGIN_FINISH_UNIT               | annobin: Generate final annotations
PLUGIN_START_UNIT                | annobin: Generate global annotations
PLUGIN_ALL_PASSES_START          | annobin: Generate per-function annotations
PLUGIN_ALL_PASSES_END            | annobin: Register per-function end symbol
In file included from /usr/include/boost/python.hpp:55,
                 from /builddir/build/BUILD/vigra-1.11.1/include/vigra/numpy_array_converters.hxx:41,
                 from /builddir/build/BUILD/vigra-1.11.1/vigranumpy/src/core/sampling.cxx:40:
/usr/include/boost/python/raw_function.hpp: In member function 'PyObject* boost::python::detail::raw_dispatcher<F>::operator()(PyObject*, PyObject*)':
/usr/include/boost/python/raw_function.hpp:33:76: internal compiler error: in nothrow_spec_p, at cp/except.c:1247
   33 |                     , keywords ? dict(borrowed_reference(keywords)) : dict()
      |   

This is blocked by bz1794094 and blocks the Python 3.9 rebuild of vigra.

Comment 1 Bruno Postle 2020-01-28 08:17:12 UTC
Closing as this looks like a compiler or hardware problem, and subsequent builds are ok.