Bug 179470

Summary: Mkinitrd fail if "strip" for modules not recognize file format
Product: [Fedora] Fedora Reporter: Alexander Shiyan <shc>
Component: mkinitrdAssignee: Peter Jones <pjones>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: medium    
Version: rawhideCC: greenrd
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-03 18:19:33 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexander Shiyan 2006-01-31 12:02:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); ru-RU; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
I wrote patch for mkinird, which ignore errors on strip modules.
This errors must be present if install kernel for x86-64 arch when
strip program is not support x86-64.
Today I upgrade my machine from Pentium-II to Pentium 4 D with EM64T support
and want try use x86-64 kernel. With this patch is done. Patch I place in field "Additional information".


Version-Release number of selected component (if applicable):
mkinitrd-5.0.17-1

How reproducible:
Always

Steps to Reproduce:
1.On alredy installed ia32 system (on x86-64 machine) try to install x86-64 kernel.


Actual Results:  inird image not contain modules.

Additional info:

--- mkinitrd.orig       2006-01-04 03:50:37.000000000 +0300
+++ mkinitrd    2006-01-31 18:50:13.000000000 +0300
@@ -698,7 +698,7 @@

 for MODULE in $MODULES; do
     if [ -x /usr/bin/strip ]; then
-       /usr/bin/strip -g $verbose $MODULE -o $MNTIMAGE/lib/$(basename $MODULE)
+       /usr/bin/strip -g $verbose $MODULE -o $MNTIMAGE/lib/$(basename $MODULE) 2>/dev/null || cp $verbose -a $MODULE $MNTIMAGE/lib
     else
        cp $verbose -a $MODULE $MNTIMAGE/lib
     fi
Comment 1 Robin Green 2008-03-02 06:32:35 EST
Why is this marked not a bug? It is a bug, with a patch included to fix it.