Bug 1795035

Summary: [OpenStack] CAPO doesn't report failure if it can't read cloud provider CA cert
Product: OpenShift Container Platform Reporter: Martin André <m.andre>
Component: InstallerAssignee: Martin André <m.andre>
Installer sub component: OpenShift on OpenStack QA Contact: David Sanz <dsanzmor>
Status: CLOSED ERRATA Docs Contact:
Severity: low    
Priority: unspecified    
Version: 4.4   
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: CAPO doesn't print any errors in the logs when it cannot read the cloud provider CA certificate from the `openshift-config/cloud-provider-config` configmap. Consequence: It makes it difficult to debug if anything goes wrong while retrieving the certificate. Fix: Log the failure before initiating the connection to the cloud provider. Result: It is now easier to troubleshoot issues with self-signed certificates.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-04 11:26:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin André 2020-01-26 15:27:45 UTC
In the case where CAPO cannot read the cloud provider CA certificate from the `openshift-config/cloud-provider-config` configmap, it should log the failure before initiating the connection to the cloud provider as if no CA cert was specified.

Currently it doesn't print any errors in the logs making it difficult to debug if anything goes wrong while retrieving the certificate.

Comment 2 David Sanz 2020-02-04 09:57:24 UTC
Verified on 4.4.0-0.nightly-2020-02-04-014809

Comment 4 errata-xmlrpc 2020-05-04 11:26:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581