Bug 1795674

Summary: mpich depends on redhat-rpm-config
Product: [Fedora] Fedora Reporter: david08741
Component: mpichAssignee: Zbigniew Jędrzejewski-Szmek <zbyszek>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: dakingun, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-04 22:58:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description david08741 2020-01-28 15:46:19 UTC
Description of problem:
mpich depends on redhat-rpm-config

Version-Release number of selected component (if applicable):
mpich-devel-3.3.2-1.fc32.x86_64

How reproducible:
Always

Steps to Reproduce:
1. dnf install mpich-devel gcc-c++
2. mpic++ --version

Actual results:
g++: fatal error: cannot read spec file ‘/usr/lib/rpm/redhat/redhat-hardened-cc1’: No such file or directory
compilation terminated.


Expected results:
g++ (GCC) 10.0.1 20200123 (Red Hat 10.0.1-0.5)
Copyright (C) 2020 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


Additional info:
`dnf install /usr/lib/rpm/redhat/redhat-hardened-cc1`
resolves this issue.

Comment 1 Zbigniew Jędrzejewski-Szmek 2020-01-29 09:01:03 UTC
I can't reproduce this:

$ mock -i result/mpich-3.3.2-1.fc32.x86_64.rpm result/mpich-devel-3.3.2-1.fc32.x86_64.rpm
$ mock --shell
# module load mpi/mpich-x86_64
# mpic++ --version
g++ (GCC) 10.0.1 20200123 (Red Hat 10.0.1-0.5)
Copyright (C) 2020 Free Software Foundation, Inc.
...

Comment 2 david08741 2020-01-29 11:05:43 UTC
mock seems to have redhat-rpm-config pre-installed. If you come from a clean system without redhat-rpm-config installed, that is not the case.

$ podman --rm -it run fedora:rawhide
# dnf install mpich-devel environment-modules
# . /etc/profile
# module load mpi
# mpicc --version

You should also be able to do this, by uninstalling redhat-rpm-config first, then installing mpich-devel.

Comment 3 Ben Cotton 2020-02-11 17:23:14 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.