Bug 1796468

Summary: simplified telemetry metrics configuration is not active
Product: OpenShift Container Platform Reporter: Sergiusz Urbaniak <surbania>
Component: MonitoringAssignee: Frederic Branczyk <fbranczy>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.4CC: alegrand, anpicker, erooth, fbranczy, juzhao, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-04 11:28:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sergiusz Urbaniak 2020-01-30 13:51:24 UTC
With https://github.com/openshift/cluster-monitoring-operator/pull/617 we merged an A/B flag for Prometheus Remote Write with telemeter-client being still the default.

Alongside we also switched over to the simplified metrics configuration scheme but did it is not active yet. This needs to be fixed.

Comment 3 Lili Cosic 2020-02-03 12:41:31 UTC
Can you check that the cluster is sending telemetry. So the normal telemetry check, let me know if you have any questions, thanks!

Comment 4 Junqi Zhao 2020-02-04 00:42:27 UTC
(In reply to Lili Cosic from comment #3)
> Can you check that the cluster is sending telemetry. So the normal telemetry
> check, let me know if you have any questions, thanks!

see Comment 2, telemeter client can send metrics to server.
close this bug as VERIFIED

Comment 6 errata-xmlrpc 2020-05-04 11:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581