Bug 1796851

Summary: Recipe stuck in Scheduled state due to kickstart being too big to be stored in the database
Product: [Community] Beaker Reporter: Ales Zelinka <azelinka>
Component: schedulerAssignee: Martin Styk <mastyk>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 26CC: bpeck, cbouchar, jkriz, mastyk
Target Milestone: 28.0Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-12-16 18:50:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ales Zelinka 2020-01-31 12:10:35 UTC
Description of problem:
For some recipes, the valid generated kickstart is so big it doesn't fit into the database "rendered_kickstart" table "kickstart" column (of size 65535).

beakerd tries repeatedly and fails repeatedly, the recipe stays in Scheduled state.

How reproducible:
Have a recipe with a huge kickstart, e.g. clone this one:
https://beaker.engineering.redhat.com/recipes/7853762#installation

Additional info:
The kickstart of the linked recipe is so big because 
a) it is a group job, group having +- 70 members
b) Beaker adds all the ssh keys of all the group members to the kickstart 

The ssh-keys portion of the kickstrat is 40k.

beaker-server error log:
http://pastebin.test.redhat.com/832120

pretty-printed part of the kickstart as parsed from the log message:
http://pastebin.test.redhat.com/832123

Comment 1 Martin Styk 2020-06-16 16:29:22 UTC
Space usable for Kickstart is now 2 ** 24 - 1.
In case you will breach even this limit, the job is aborted.