Bug 1797800

Summary: Deprecated command `operator-sdk generate openapi` in operator-sdk getting started document needs to be updated
Product: OpenShift Container Platform Reporter: Harish Govindarajulu <hgovinda>
Component: Operator SDKAssignee: Joe Lanford <jlanford>
Status: CLOSED ERRATA QA Contact: Fan Jia <jfan>
Severity: low Docs Contact:
Priority: unspecified    
Version: 4.4CC: aos-bugs
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-06-29 15:33:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Harish Govindarajulu 2020-02-03 21:46:42 UTC
Description of problem:
Below document references `operator-sdk generate openapi` deprecated command
https://github.com/operator-framework/getting-started#build-an-operator-using-the-operator-sdk


Expected results:
Update the document to use the new correct command:  operator-sdk generate crds


Additional info:

Comment 6 errata-xmlrpc 2020-06-29 15:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713