Bug 1798220

Summary: No longer able to pass additional descheduler flags to descheduler-operator
Product: OpenShift Container Platform Reporter: Mike Dame <mdame>
Component: kube-schedulerAssignee: Mike Dame <mdame>
Status: CLOSED ERRATA QA Contact: RamaKasturi <knarra>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.4CC: aos-bugs, mfojtik, yinzhou
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-04 11:33:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Dame 2020-02-04 20:39:35 UTC
PR https://github.com/openshift/cluster-kube-descheduler-operator/pull/66 inadvertently removed the ability to pass additional flags (beyond those that are operator parameters, such as `--dry-run`) to the descheduler. This should be re-enabled

Comment 1 Mike Dame 2020-02-04 20:41:29 UTC
QA: This can be tested by attempting to deploy the descheduler operator with an additional flag, such as:

```
flags:
 - --dry-run
```

Comment 6 errata-xmlrpc 2020-05-04 11:33:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581