Bug 180024

Summary: Permissions of /dev/fuse revert to 0600
Product: [Fedora] Fedora Reporter: James <theholyettlz>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: hakon.kippe, steve.traylen, wtogami, yeti
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-08 07:35:59 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description James 2006-02-04 16:00:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
When the system is started, udev sets the permissions of /dev/fuse to 0660. However, as soon as anything is mounted these revert to 0600. Subsequent mounts by members of the fuse group are impossible. (Inconvenient as I need a fuse-supplied filesystem to be mounted at boot.)

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1830_FC4

How reproducible:
Always

Steps to Reproduce:
1. Mount an sshfs system (e.g.).
2. Unmount it.
3. Attempt to remount.
  

Actual Results:  fusermount: failed to open /dev/fuse: Permission denied


Expected Results:  Mounted OK.

Additional info:

fuse-2.4.2-2.fc4, etc.
udev-071-0.FC4.2
Comment 1 James 2006-02-05 13:18:42 EST
This problem seems to be solved by (1) adding the line

    install fuse /sbin/modprobe --ignore-install fuse ; chmod 0660 /dev/fuse ;
chgrp fuse /dev/fuse

to /etc/modprobe.conf; (2) removing /etc/udev/makedev.d/40-fuse.nodes; and (3)
creating an 0700 (or whatever) shell script /etc/sysconfig/modules/fuse.modules
containing

    #!/bin/sh
    /sbin/modprobe fuse

Comment 2 Harald Hoyer 2006-02-08 07:35:59 EST
fuse should offer /etc/udev/rules.d/40-fuse.rules
Comment 3 Warren Togami 2006-02-09 01:24:38 EST
I didn't have to do anything special other than add my user to the fuse group,
and fedora extras fuse package works fine without any
/etc/udev/rules.d/40-fuse.rules file.  This is with both FC4 and FC5 with extras
fuse-*.
Comment 4 James 2006-02-09 05:15:09 EST
OK, I'll try... I've removed all my modifications and replaced
/etc/udev/makedev.d/40-fuse.nodes. (I've never removed
/etc/udev/rules.d/40-fuse.rules.) Immediately after starting:


[james@harmony ~]$ stat /dev/fuse
  File: `/dev/fuse'
  Size: 0               Blocks: 0          IO Block: 4096   character special file
Device: fh/15d  Inode: 1731        Links: 1     Device type: a,e5
Access: (0660/crw-rw----)  Uid: (    0/    root)   Gid: (  105/    fuse)
Access: 2006-02-09 10:05:29.964736250 +0000
Modify: 2006-02-09 10:05:29.964736250 +0000
Change: 2006-02-09 10:05:29.964736250 +0000
[james@harmony ~]$ sshfs molly: mnt/molly
james@molly's password:


It's now mounted OK.


[james@harmony ~]$ fusermount -u mnt/molly
[james@harmony ~]$ stat /dev/fuse
  File: `/dev/fuse'
  Size: 0               Blocks: 0          IO Block: 4096   character special file
Device: fh/15d  Inode: 1731        Links: 1     Device type: a,e5
Access: (0600/crw-------)  Uid: (    0/    root)   Gid: (  105/    fuse)
Access: 2006-02-09 10:05:29.964736250 +0000
Modify: 2006-02-09 10:05:29.964736250 +0000
Change: 2006-02-09 10:09:01.000000000 +0000
[james@harmony ~]$ sshfs molly: mnt/molly
james@molly's password:
fusermount: failed to open /dev/fuse: Permission denied


The fuse-* and udev rpms all verify OK. I'm beginning to think I've some
misconfiguration error possibly from previous installations of fuse (done from
sources at SF), but I can't think where. I read somewhere that the fuse module
itself recreates /dev/fuse...
Comment 5 Håkon Kippe 2014-10-02 06:16:58 EDT
I had the same problem (Fedora 20). Uninstalling and reinstalling fuse fixed it.
Comment 6 David Nečas 2014-11-10 07:26:03 EST
I have the same problem in Fedora 20 on several machines after a relatively recent update.  Current versions:

fuse-2.9.3-2.fc20.x86_64
fuse-sshfs-2.4-5.fc20.x86_64

Even tried removing and installing fuse again (as suggested in comment 5) but it did not help.
Comment 7 Steve Traylen 2014-11-11 02:54:02 EST
I may seeing this on CentOS 7 also.
Comment 8 Harald Hoyer 2014-11-11 07:06:57 EST
(In reply to Steve Traylen from comment #7)
> I may seeing this on CentOS 7 also.

please open a new bug against component "fuse" for this