Bug 1800513

Summary: Generate test fails when updating deps
Product: OpenShift Container Platform Reporter: Lili Cosic <lcosic>
Component: MonitoringAssignee: Lili Cosic <lcosic>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: alegrand, anpicker, erooth, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-02-19 05:40:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1800519    
Bug Blocks:    

Description Lili Cosic 2020-02-07 10:10:25 UTC
Description of problem:
Whenever adding new changes, the generate check fails because we have not run jb update.

Comment 2 Junqi Zhao 2020-02-10 04:30:21 UTC
@Lili
Tested with 4.3.0-0.nightly-2020-02-09-195913, I see the fix is in the image, example
# oc -n openshift-monitoring get deploy prometheus-operator -oyaml 
...
  labels:
    app.kubernetes.io/component: controller
    app.kubernetes.io/name: prometheus-operator
    app.kubernetes.io/version: v0.34.1
...
  template:
    metadata:
      creationTimestamp: null
      labels:
        app.kubernetes.io/component: controller
        app.kubernetes.io/name: prometheus-operator
        app.kubernetes.io/version: v0.34.1
...

But I see in the prometheus-operator pod's log, the vesion is still 0.34.0, should it be 0.34.1?
# oc -n openshift-monitoring logs prometheus-operator-98d6fb856-99rsl | head
ts=2020-02-10T02:36:20.910391444Z caller=main.go:199 msg="Starting Prometheus Operator version '0.34.0'."

Since the issue in this bug is fixed, close it, if the report version is wrong, will file another bug

Comment 3 Lili Cosic 2020-02-10 10:56:30 UTC
We will need a new bugzilla for that, as we want to port the fix to 4.3 as well. But thats separate from this, so new bugzilla is correct for 4.3 to have 0.34.1.

Comment 5 errata-xmlrpc 2020-02-19 05:40:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0492