Bug 1801076

Summary: Installing pki-server on Fedora rawhide fails due to broken dependencies
Product: [Fedora] Fedora Reporter: Jan Pazdziora <jpazdziora>
Component: pki-coreAssignee: Matthew Harmsen <mharmsen>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: alee, ascheel, dmoluguw, edewata, jpazdziora, kwright, mharmsen
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-02-12 17:35:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Jan Pazdziora 2020-02-10 08:16:24 UTC
Description of problem:

Attempts to install pki-server (as part of the freeipa-server installation) fails on Fedora rawhide.

Version-Release number of selected component (if applicable):

pki-server-10.7.3-6.fc32.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. dnf install pki-server

Actual results:

# dnf install pki-server
Fedora - Modular Rawhide - Developmental packages for the next Fedora release                                                           6.3 MB/s | 4.4 MB     00:00    
Fedora - Rawhide - Developmental packages for the next Fedora release                                                                    23 MB/s |  70 MB     00:03    
Error: 
 Problem: package tomcatjss-7.4.1-3.fc32.noarch requires slf4j-jdk14, but none of the providers can be installed
  - package pki-server-10.7.3-6.fc32.noarch requires tomcatjss >= 7.4.1, but none of the providers can be installed
  - package slf4j-jdk14-1.7.30-1.fc32.noarch requires mvn(org.slf4j:slf4j-api) = 1.7.30, but none of the providers can be installed
  - conflicting requests
  - package slf4j-1.7.30-1.fc32.noarch is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages)

Expected results:

No error.

Additional info:

Filing against pki-core because I don't know if the tomcatjss (and its dependencies) are actually supposed to be pulled in.

Comment 2 Ben Cotton 2020-02-11 16:34:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 3 Dinesh Prasanth 2020-02-12 17:35:30 UTC
The issue seems to be due to the latest slf4j that was released as ursine rpm.
The conflict is due to pre-enabled modules: maven and ant

The temporary work around is by disabling maven:

# dnf module disable maven

This is not a pki bug but rather an issue with modules. So, I am marking this bug as a duplicate of BZ#1801882

*** This bug has been marked as a duplicate of bug 1801882 ***