Bug 1801343

Summary: Host parsing from resolv.conf doesn't handle IPv6 with %zone info
Product: OpenShift Container Platform Reporter: Brad P. Crochet <brad>
Component: NetworkingAssignee: Dan Mace <dmace>
Networking sub component: DNS QA Contact: Hongan Li <hongli>
Status: CLOSED ERRATA Docs Contact:
Severity: unspecified    
Priority: unspecified CC: aos-bugs, hongli
Version: 4.3.0   
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1801339 Environment:
Last Closed: 2020-03-10 23:53:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1801339    
Bug Blocks:    

Description Brad P. Crochet 2020-02-10 17:00:05 UTC
+++ This bug was initially created as a clone of Bug #1801339 +++

If an IPv6 address with %zone info appended is in resolv.conf the parsing does not work properly. It does not properly identify as an IPv6 address, and causes panic.

Comment 3 Hongan Li 2020-02-20 11:40:57 UTC
verified with 4.3.0-0.nightly-2020-02-20-033504 and coredns has been updated to 1.6.6

$ oc -n openshift-dns exec dns-default-262fc -c dns -- coredns -version
CoreDNS-1.6.6
linux/amd64, go1.12.12,

Comment 5 errata-xmlrpc 2020-03-10 23:53:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676