Bug 1801660

Summary: Some schema data is missing on explore page
Product: OpenShift Container Platform Reporter: Samuel Padgett <spadgett>
Component: Management ConsoleAssignee: Jakub Hadvig <jhadvig>
Status: CLOSED ERRATA QA Contact: XiaochuanWang <xiaocwan>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: aos-bugs, bpeterse, jhadvig, jokerman, sgoodwin, yapei
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1789602 Environment:
Version: 4.4.0-0.ci-2020-01-08-115313 Cluster ID: 20c547b3-48fd-4c0a-b9a1-e71ebf55c4f1 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0
Last Closed: 2020-03-10 23:53:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1789602    
Bug Blocks:    

Description Samuel Padgett 2020-02-11 13:06:41 UTC
+++ This bug was initially created as a clone of Bug #1789602 +++

`oc explain` should the right detail for `consoleclidownload.spec.links`, but the fields and descriptions are missing from the console explore page. (See scerenshot.)

$ oc explain consoleclidownload.spec.links
KIND:     ConsoleCLIDownload
VERSION:  console.openshift.io/v1

RESOURCE: links <[]Object>

DESCRIPTION:
     links is a list of objects that provide CLI download link details.

FIELDS:
   href <string> -required-
     href is the absolute secure URL for the link (must use https)

   text <string>
     text is the display text for the link

Comment 1 bpeterse 2020-02-12 04:52:03 UTC
PR opened & waiting for the 4.4 bug to be verified
https://github.com/openshift/console/pull/4281

Comment 4 XiaochuanWang 2020-02-28 06:17:14 UTC
Schema page display correctly as consoleclidownload.spec.links
Verified on 4.3.0-0.nightly-2020-02-27-225047

Comment 6 errata-xmlrpc 2020-03-10 23:53:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676