Bug 1804726

Summary: RFE: Complete among match support in ebtables-nft
Product: Red Hat Enterprise Linux 8 Reporter: Phil Sutter <psutter>
Component: iptablesAssignee: Phil Sutter <psutter>
Status: CLOSED ERRATA QA Contact: Tomas Dolezal <todoleza>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.3CC: iptables-maint-list, todoleza
Target Milestone: rcKeywords: FutureFeature
Target Release: 8.3   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: iptables-1.8.4-11.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-04 01:54:58 UTC Type: Feature Request
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Phil Sutter 2020-02-19 14:13:46 UTC
Upstream recently received full among match support by making use of concatenated ranges support in nftables:

commit c33bae9c6c7a49c8af16df846e6112fc4727e643
Author: Phil Sutter <phil@nwl.cc>
Date:   Thu Feb 13 17:49:53 2020 +0100

    ebtables: among: Support mixed MAC and MAC/IP entries
    
    Powered by Stefano's support for concatenated ranges, a full among match
    replacement can be implemented. The trick is to add MAC-only elements as
    a concatenation of MAC and zero-length prefix, i.e. a range from
    0.0.0.0 till 255.255.255.255.
    
    Although not quite needed, detection of pure MAC-only matches is left in
    place. For those, no implicit 'meta protocol' match is added (which is
    required otherwise at least to keep nft output correct) and no concat
    type is used for the set.
    
    Signed-off-by: Phil Sutter <phil@nwl.cc>

Comment 7 errata-xmlrpc 2020-11-04 01:54:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (iptables bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4518