Bug 1804956

Summary: efibootmgr segfault at error 4 in libc-2.31.so
Product: [Fedora] Fedora Reporter: Chris Murphy <bugzilla>
Component: efibootmgrAssignee: Peter Jones <pjones>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: awilliam, bugzilla, pjones, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-02-20 00:22:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Chris Murphy 2020-02-20 00:11:57 UTC
Description of problem:

efibootmgr crashes during installation, 


Version-Release number of selected component (if applicable):
efibootmgr-16-7.fc32.x86_64
glibc-2.31-1.fc32.x86_64
efivar-libs-37-5.fc32.x86_64
kernel-5.6.0-0.rc2.git0.1.fc32.x86_64


How reproducible:
Always


Steps to Reproduce:
1. efibootmgr -c -w -L Fedora -d /dev/vda -p 1 -l \\EFI\\fedora\\shimx64.efi

2.
3.

Actual results:

Segmentation fault (core dumped)

Expected results:

It shouldn't crash

Additional info:


[  700.900353] efibootmgr[17437]: segfault at 55bec7906cee ip 00007fd37c0eceaa sp 00007ffeb04b68d8 error 4 in libc-2.31.so[7fd37c072000+150000]
[  700.900361] Code: f3 0f 1e fa 66 0f ef c0 66 0f ef c9 66 0f ef d2 66 0f ef db 48 89 f8 48 89 f9 48 81 e1 ff 0f 00 00 48 81 f9 cf 0f 00 00 77 66 <f3> 0f 6f 20 66 0f 74 e0 66 0f d7 d4 85 d2 74 04 0f bc c2 c3 48 83


7 EST   34975     0     0  11 present   /usr/sbin/efibootmgr
[root@localhost-live ~]# coredumpctl info 17437
           PID: 17437 (efibootmgr)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Wed 2020-02-19 18:44:37 EST (26min ago)
  Command Line: efibootmgr -c -w -L Fedora -d /dev/vda -p 1 -l \EFI\fedora\shimx64.efi
    Executable: /mnt/sysroot/usr/sbin/efibootmgr
 Control Group: /user.slice/user-1000.slice/user/gnome-launched-fedora-welcome.desktop-1915.scope
          Unit: user
     User Unit: gnome-launched-fedora-welcome.desktop-1915.scope
         Slice: user-1000.slice
     Owner UID: 1000 (liveuser)
       Boot ID: 785db08f0e184ab9b33b1aa0304034b8
    Machine ID: 26336922e1044e80ae4bd42e1d6b9099
      Hostname: localhost-live
       Storage: /var/lib/systemd/coredump/core.efibootmgr.0.785db08f0e184ab9b33b1aa0304034b8.17437.1582155877000000000000.lz4
       Message: Process 17437 (efibootmgr) of user 0 dumped core.
                
                Stack trace of thread 17437:
                #0  0x00007fd37c0eceaa __GI___strlen_sse2 (libc.so.6 + 0x9feaa)
                #1  0x00007fd37c224494 parse_acpi_root (libefiboot.so.1 + 0xd494)
                #2  0x00007fd37c21e84d device_get (libefiboot.so.1 + 0x784d)
                #3  0x00007fd37c2256cd efi_va_generate_file_device_path_from_esp (libefiboot.so.1 + 0xe6cd)
                #4  0x00007fd37c2267dd efi_generate_file_device_path_from_esp (libefiboot.so.1 + 0xf7dd)
                #5  0x000055be996677ef make_linux_load_option (efibootmgr + 0x67ef)
                #6  0x000055be99664cb2 main (efibootmgr + 0x3cb2)
                #7  0x00007fd37c074042 __libc_start_main (libc.so.6 + 0x27042)
                #8  0x000055be99665e9e _start (efibootmgr + 0x4e9e)

Comment 1 Fedora Blocker Bugs Application 2020-02-20 00:13:27 UTC
Proposed as a Blocker for 32-beta by Fedora user chrismurphy using the blocker tracking app because:

 Basic: "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."

Comment 2 Chris Murphy 2020-02-20 00:13:58 UTC
Looks the same as this:
https://openqa.fedoraproject.org/tests/523592#step/_do_install_and_reboot/52

Comment 3 Adam Williamson 2020-02-20 00:22:55 UTC
I filed this three bugs ago...

*** This bug has been marked as a duplicate of bug 1804953 ***