Bug 180503

Summary: after update to kernel 2.6.15-1.1831_FC4 wireless card ipw2200 don't work
Product: [Fedora] Fedora Reporter: Claudio Penasio Junior <penasio>
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED DEFERRED QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: adam, alriddoch, armel.kermorvant, davej, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-04-21 17:15:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Claudio Penasio Junior 2006-02-08 17:56:47 UTC
Description of problem:
after yum update in 02-07-2006, my wireless network card (ipw2200) don't work
anymore.

Version-Release number of selected component (if applicable):
2.6.15-1.1831_FC4

How reproducible:
dmesg | grep eth 
eth0: Broadcom 4400 10/100BaseT Ethernet 00:12:3f:f1:12:e4
ADDRCONF(NETDEV_UP): eth0: link is not ready
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is on for TX and on for RX.
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
eth0: no IPv6 routers present

don't show eth1

dmesg | grep ipw2200
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, git-1.0.8
ipw2200: Copyright(c) 2003-2005 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw-2.4-boot.fw load failed: Reason -2
ipw2200: Unable to load firmware: -2
ipw2200: failed to register network device
ipw2200: probe of 0000:02:03.0 failed with error -5

don't load the firmware

Steps to Reproduce:
1. dmesg | grep eth 
2. dmesg | grep ipw2200
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Armel Kermorvant 2006-02-11 19:14:26 UTC
Good Afternoon,

I confirm this bug,I update my kernel on my NEC S940 notebook with the IPW2200
and the Wifi doesn't work.
I remove de network adapter on the network software (KDE) and when a go into the
Harware and I chood Afternoon,

I confirm this bug,I update my kernel on my NEC S940 notebook with the IPW2200
and the Wifi doesn't work.
I remove the  Wifi adapter the system doesn't file the hardware.
I come back on the previous kernel version, the system find the new hardware
(IPW2200) and the system works again.

I hope you find a workaround.

Have a nice day

Armelk

Comment 2 Armel Kermorvant 2006-02-11 19:15:09 UTC
Good Afternoon,

I confirm this bug,I update my kernel on my NEC S940 notebook with the IPW2200
and the Wifi doesn't work.
I remove de network adapter on the network software (KDE) and when a go into the
Harware and I chood Afternoon,

I confirm this bug,I update my kernel on my NEC S940 notebook with the IPW2200
and the Wifi doesn't work.
I remove the  Wifi adapter the system doesn't file the hardware.
I come back on the previous kernel version, the system find the new hardware
(IPW2200) and the system works again.

I hope you find a workaround.

Have a nice day

Armelk

Comment 3 Alistair Riddoch 2006-02-17 13:44:29 UTC
I have the same problem. The newer driver appears to require a new version 2.4 of
the firmware, which is available from ipw2200.sourceforge.net. However, once the
new firmware is installed, the driver reports this message in the syslog, and
does not work as expected:

Feb 17 13:37:58 carom kernel: eth1: NETDEV_TX_BUSY returned; driver should
report queue full via ieee_device->is_queue_full.


Comment 4 Claudio Penasio Junior 2006-02-23 17:19:34 UTC
Hello,
I erased the old version of the firmware (2.2), and install the new version from
ipw2200.sourceforge.net (2.4). Now my card work as expected, however a error
message is displayed at dhcp configuration.

Comment 5 John W. Linville 2006-02-27 17:04:46 UTC
Claudio, what is the dhcp error? 

Comment 6 John W. Linville 2006-04-21 17:15:50 UTC
Closed due to lack of response.  Please reopen when the requested information 
becomes available...thanks! 

Comment 7 Alistair Riddoch 2006-04-23 22:18:24 UTC
The error message described in my comment above no longer occurs with recent
kernels.