Bug 1805190

Summary: Telemeter payload limit is too small for larger clusters
Product: OpenShift Container Platform Reporter: Sergiusz Urbaniak <surbania>
Component: MonitoringAssignee: Sergiusz Urbaniak <surbania>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: low Docs Contact:
Priority: unspecified    
Version: 4.4CC: alegrand, anpicker, erooth, juzhao, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1805188
: 1805317 (view as bug list) Environment:
Last Closed: 2020-05-13 21:59:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1805188    
Bug Blocks: 1805317    

Description Sergiusz Urbaniak 2020-02-20 13:16:30 UTC
+++ This bug was initially created as a clone of Bug #1805188 +++

This is related to https://bugzilla.redhat.com/show_bug.cgi?id=1794616, but not optimizing the payload size, but we have to also bump the transfer limit for telemeter client.

Otherwise, larger clusters will still fail to send telemetry data.

Comment 3 Junqi Zhao 2020-02-24 03:58:34 UTC
Tested with 4.4.0-0.nightly-2020-02-23-191320, limit-bytes is now 5Mb
# oc -n openshift-monitoring get deploy/telemeter-client -oyaml | grep "\- --limit-bytes"
        - --limit-bytes=5242880

Comment 5 errata-xmlrpc 2020-05-13 21:59:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581