Bug 1805445

Summary: Ensure kube-apiserver advertises the correct IP on bare metal clusters
Product: OpenShift Container Platform Reporter: Russell Bryant <rbryant>
Component: kube-apiserverAssignee: Stefan Schimanski <sttts>
Status: CLOSED ERRATA QA Contact: Ke Wang <kewang>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 4.4CC: aos-bugs, mcornea, mfojtik, xxia
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1805449 1805865 (view as bug list) Environment:
Last Closed: 2020-05-04 11:38:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1805449    
Bug Blocks: 1805865    

Description Russell Bryant 2020-02-20 19:48:25 UTC
On a bare metal cluster, kube-apiserver's default behavior for choosing which IP to advertise may choose the wrong IP on a bare metal cluster that has some Virtual IPs.  See this PR for more details: https://github.com/openshift/cluster-kube-apiserver-operator/pull/760

Comment 4 errata-xmlrpc 2020-05-04 11:38:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581