Bug 1807141

Summary: Alert on OOMKills on the cluster as a symptom of disruptive workloads or bugs
Product: OpenShift Container Platform Reporter: Clayton Coleman <ccoleman>
Component: NodeAssignee: Ryan Phillips <rphillips>
Status: CLOSED ERRATA QA Contact: Sunil Choudhary <schoudha>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: aos-bugs, jokerman, lcosic, schoudha
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1807140 Environment:
Last Closed: 2020-05-11 21:20:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1807140    
Bug Blocks:    

Description Clayton Coleman 2020-02-25 17:10:25 UTC
+++ This bug was initially created as a clone of Bug #1807140 +++

+++ This bug was initially created as a clone of Bug #1807139 +++

An OOMKill on a cluster can be disruptive to workloads and infrastructure both immediately and over time (if a component partially fails).  We should alert when a significant number of OOMKills have occurred.

As a starting point, we should pick a rate that we believe is likely to indicate serious problems and tune it down (to catch more issues) after we assess the impact in the field.  The alert should be at 'info' level for now in order to allow time for assessment.

Should be back ported to 4.3 where OOMKills may have caused significant production issues for a few customers.

Comment 1 Lili Cosic 2020-03-05 11:07:42 UTC
I will not have time to do this backport, due to other higher priority bugzillas and tasks. Resetting to the node team.

Comment 7 errata-xmlrpc 2020-05-11 21:20:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2006