Bug 1808118

Summary: Image Registry Operator Log Level Cannot Be Changed
Product: OpenShift Container Platform Reporter: Adam Kaplan <adam.kaplan>
Component: Image RegistryAssignee: Ricardo Maraschini <rmarasch>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.1.zCC: aos-bugs, obulatov, rmarasch, xiuwang
Target Milestone: ---   
Target Release: 4.6.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Feature: Allow users to set log level separately for image registry operator and operand. Reason: Users could not set log levels for the operator in case of debug needs. Result: Users can now set log levels seprately using two distinct fields: - LogLevel (applies to the operand) - OperatorLogLevel (applies to the operator)
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-27 15:55:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Adam Kaplan 2020-02-27 20:39:41 UTC
Description of problem:

The log level for the image registry operator is static and set at a relatively high level (0). This cannot be changed without using a CVO override [1] or scaling the CVO deployment to 0.


Version-Release number of selected component (if applicable): 4.1.0


How reproducible: Always


Steps to Reproduce:
1. Increase the log Level of the image registry operator config to 5 (i.e. debug)
2. Tail the logs of the cluster image registry operator

Actual results:

Only high level info logs, warnings, and errors are logged


Expected results:

Debug messages are logged.


Additional info:

[1] https://github.com/openshift/cluster-version-operator/blob/master/docs/dev/clusterversion.md#setting-objects-unmanaged

Comment 2 Ricardo Maraschini 2020-05-26 15:02:23 UTC
After some discussions we have decided to move this to the next version. We have been living with this behavior for a while and to introduce a fix for it in 4.5 involve risks we are not willing to take so close to code freeze. This one requires changes on openshift/api as well as in image registry operator, we have to be careful with how we gonna tackle backward compatibility and that increases the risk.

Comment 6 Ricardo Maraschini 2020-08-21 12:35:07 UTC
Fix for this one is awaiting for review/approval.

Comment 9 Wenjing Zheng 2020-09-11 10:20:04 UTC
QE can see image registry to debug log level on 4.6.0-0.nightly-2020-09-10-195619.

Comment 11 errata-xmlrpc 2020-10-27 15:55:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196