Bug 1808431

Summary: [4.3] No global tolerations for NodeCA DaemonSet
Product: OpenShift Container Platform Reporter: Adam Kaplan <adam.kaplan>
Component: Image RegistryAssignee: Oleg Bulatov <obulatov>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.2.zCC: adam.kaplan, adeshpan, andcosta, aos-bugs, ChetRHosey, hcisneir, mharri, obulatov, rdomnu, susuresh, wzheng
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: nodeca daemon doesn't tolerate NoSchedule Consequence: it cannot be deployed on tainted nodes Fix: tolerate NoSchedule Result: the deamon can manage certificate on nodes with NoSchedule
Story Points: ---
Clone Of: 1785115
: 1808433 (view as bug list) Environment:
Last Closed: 2020-03-10 23:54:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1785115    
Bug Blocks: 1808433    

Comment 3 Wenjing Zheng 2020-03-03 11:13:08 UTC
Verified on 4.3.0-0.nightly-2020-03-02-115939.After tainting the nodes, the number of pods NodeCA DaemonSet doesn't change.

Comment 5 errata-xmlrpc 2020-03-10 23:54:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676