Bug 1808505

Summary: [4.2] Idle OpenShift 4.2 Image registry queries Azure storage keys about 40 times per minute
Product: OpenShift Container Platform Reporter: Corey Daley <cdaley>
Component: Image RegistryAssignee: Corey Daley <cdaley>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.2.zCC: aos-bugs, bparees, cdaley, esimard, japearson, mharri, obulatov, wzheng
Target Milestone: ---   
Target Release: 4.2.z   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1776665 Environment:
Last Closed: 2020-03-26 07:21:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1808426    
Bug Blocks:    

Comment 4 Wenjing Zheng 2020-03-18 03:32:57 UTC
Whether this bug fix should be reverted like other version?

Comment 5 Corey Daley 2020-03-18 14:30:01 UTC
no, 4.2 was given the correct fix for this issue since we knew that we had to not rely on infrastructures

Comment 6 Wenjing Zheng 2020-03-19 06:22:38 UTC
Thanks for your reply, Corey!
Verified on 4.2.0-0.nightly-2020-03-16-141929, no frequent "List Storage Account Keys" events appears in Activity log in Azure console.

Comment 8 errata-xmlrpc 2020-03-26 07:21:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0826