Bug 1809398

Summary: [4.2] Template router metrics listener is potentially broken by service CA rotation
Product: OpenShift Container Platform Reporter: Maru Newby <mnewby>
Component: NetworkingAssignee: Dan Mace <dmace>
Networking sub component: router QA Contact: Hongan Li <hongli>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: high CC: aos-bugs, dmace, hongli
Version: 4.2.0   
Target Milestone: ---   
Target Release: 4.2.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1771783 Environment:
Last Closed: 2020-03-18 08:58:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1771783    
Bug Blocks:    

Comment 3 Hongan Li 2020-03-09 06:50:31 UTC
Verified with 4.2.0-0.nightly-2020-03-08-215456 and the issue has been fixed.


$ oc -n openshift-ingress delete secret router-metrics-certs-default

$ oc -n openshift-ingress logs router-default-7f9886d584-crgb6
I0309 06:45:36.222501       1 template.go:637] Reloaded metrics certificate for cert file "/etc/pki/tls/metrics-certs/tls.crt" and key file "/etc/pki/tls/metrics-certs/tls.key"

Comment 5 errata-xmlrpc 2020-03-18 08:58:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0787