Bug 181041

Summary: zip drive thrashes starting with udev start during boot
Product: [Fedora] Fedora Reporter: Gerry Tool <gerry>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: kay.sievers
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-04-28 05:47:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
50-udev.rules
none
50-udev.rules
none
50-udev.rules
none
50-udev.rules
none
50-udev.rules none

Description Gerry Tool 2006-02-11 23:28:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060208 Fedora/1.5.0.1-2.1 Firefox/1.5.0.1

Description of problem:
After reboot, the system continuously accessed a zip disk in my zip drive, hdb4.  I finally rebooted and ejected the disk, starting again without it in
place.

After boot, I inserted the disk and a normal amount of activity ensued
to recognize the disk, but it will not mount.

On subsequent reboot, I noticed the thrashing starts as udev is loading.

Version-Release number of selected component (if applicable):
udev-084-1

How reproducible:
Always

Steps to Reproduce:
1.Have disk in zip drive
2.Reboot computer
3.
  

Actual Results:  As udev is loading, the light on the zip drive flickers continuously.  At the same time, there is a lot of harddrive activity.  This sequence will not stop until the zip disk is ejected.

Expected Results:  The boot should result in the zip disk being recognized, but access should stop.

Additional info:
Comment 1 Harald Hoyer 2006-02-14 04:57:29 EST
Created attachment 124605 [details]
50-udev.rules

Does this 50-udev.rules fix your issue?
Comment 2 Gerry Tool 2006-02-14 10:26:23 EST
I renamed the current  50-udev.rules file to 50-udev.rules.orig and created a
new file 50-udev.rules containing your attachment.  I checked the permissions to
see that they were still the same.

On boot, with the zip disk inserted, the startup was just as described in the
bug report above.  There is so much activity on the zip drive that startup is
really slowed down.  udev took a while to start and from that point on, the zip
drive light kept flashing until I finally ejected it near the end of startup.

Thanks for your reply.
Comment 3 Harald Hoyer 2006-02-15 07:19:56 EST
Does it help if you temporarily move away /etc/hotplug.d/default/20-hal.hotplug ??
Comment 4 Gerry Tool 2006-02-15 08:27:16 EST
The directory /etc/hotplug.d/default/ exists, but is empty.
Comment 5 Harald Hoyer 2006-02-15 12:25:56 EST
Does it help if you temporarily move away 
/sbin/lvm.static
Comment 6 Gerry Tool 2006-02-15 12:56:04 EST
I moved /sbin/lvm.static to /root and rebooted.  The disk activity on startup is
the same.  I noticed that while udev is starting,  that lights on several
devices such as a usb flash drive and my usb cardreader flash a few times and
then stop and then flash a few times and stop again for good.  The light on the
zip drive just keeps flashing forever until I eject the disk.  I have restored
/sbin/lvm.static.
Comment 7 Gerry Tool 2006-02-16 18:20:31 EST
Contrary to my initial posting, I am able to mount the zip drive after install
as long as I leave the disk ejected during boot, using

[root@fc5t2 ~]# mount -t vfat /dev/hdb4 /media/zipdisk

The thrashing still continues on boot if the disk is in the drive during boot,
and will not stop until I eject the disk.
Comment 8 Gerry Tool 2006-02-20 21:53:57 EST
This problem still exists on a fresh install of FC5T3.
Comment 9 Harald Hoyer 2006-02-22 03:27:41 EST
Created attachment 125011 [details]
50-udev.rules

Does this 50-udev.rules fix your issue?
Comment 10 Gerry Tool 2006-02-22 08:39:42 EST
Yeah!  That certainly did fix the issue.  No thrashing, and after boot, I can
click on Computer > Zip Drive and the disk is mounted and contents displayed in
a Nautilus window.

Thanks for your persistent efforts.  I'm not sure what the proper closure
comment should be, since I don't know if this file is yet in rawhide.  For my
part, you can close the bug or let me know what I should do.

Thanks again.
Comment 11 Harald Hoyer 2006-02-22 08:51:18 EST
Please provide the output of:
$ udevinfo -q all -n /dev/hdb4
Comment 12 Harald Hoyer 2006-02-22 08:52:52 EST
and:
$ udevinfo -a -p /sys/block/hdb/hdb4
Comment 13 Gerry Tool 2006-02-22 09:09:20 EST
The zip drive is currently mounted.  Here they are:

[gerry@fc5t3 ~]$ udevinfo -q all -n /dev/hdb4
no record for 'hdb4' in database

[gerry@fc5t3 ~]$ udevinfo -a -p /sys/block/hdb/hdb4

udevinfo starts with the device the node belongs to and then walks up the
device chain, to print for every device found, all possibly useful attributes
in the udev key format.
Only attributes within one device section may be used together in one rule,
to match the device for which the node will be created.

  looking at device '/block/hdb/hdb4':
    KERNEL=="hdb4"
    SUBSYSTEM=="block"
    SYSFS{stat}=="     297      297        0        0"
    SYSFS{size}=="196576"
    SYSFS{start}=="32"
    SYSFS{dev}=="3:68"

  looking at device '/block/hdb':
    ID=="hdb"
    BUS=="block"
    DRIVER==""
    SYSFS{stat}=="     310       95     1161    26032        0        0        0
       0        0    21904    26032"
    SYSFS{size}=="196608"
    SYSFS{removable}=="1"
    SYSFS{range}=="64"
    SYSFS{dev}=="3:64"

  looking at device '/devices/pci0000:00/0000:00:11.1/ide0/0.1':
    ID=="0.1"
    BUS=="ide"
    DRIVER=="ide-floppy"
    SYSFS{modalias}=="ide:m-floppy"
    SYSFS{drivename}=="hdb"
    SYSFS{media}=="floppy"

  looking at device '/devices/pci0000:00/0000:00:11.1/ide0':
    ID=="ide0"
    BUS==""
    DRIVER==""

  looking at device '/devices/pci0000:00/0000:00:11.1':
    ID=="0000:00:11.1"
    BUS=="pci"
    DRIVER=="VIA_IDE"
    SYSFS{modalias}=="pci:v00001106d00000571sv00001106sd00000571bc01sc01i8a"
    SYSFS{local_cpus}=="1"
    SYSFS{irq}=="11"
    SYSFS{class}=="0x01018a"
    SYSFS{subsystem_device}=="0x0571"
    SYSFS{subsystem_vendor}=="0x1106"
    SYSFS{device}=="0x0571"
    SYSFS{vendor}=="0x1106"

  looking at device '/devices/pci0000:00':
    ID=="pci0000:00"
    BUS==""
    DRIVER==""

Comment 14 Kay Sievers 2006-02-22 18:21:22 EST
We can probably just skip all ide-floppy and ide-cs devices instead of using the
"removable" rule?
  BUS=="ide", DRIVER=="ide-floppy|ide-cs", GOTO="persistent_end
Comment 15 Harald Hoyer 2006-02-23 02:25:29 EST
Created attachment 125085 [details]
50-udev.rules

Gerry, could you please test the attached file again for your fellow zip drive
users? :)
Comment 16 Harald Hoyer 2006-02-23 02:32:32 EST
Created attachment 125086 [details]
50-udev.rules

Oops, wrong one...
Comment 17 Gerry Tool 2006-02-23 08:59:06 EST
The last script you attached (id=125085) causes the thrashing of the zip drive
to return after udev has started.  I ejected it after a while to resume normal
startup speed.

In addition, a group of messages occurred like:
udevd - event[xxx] execution of /etc/udev/scripts/check-cdrom.sh failed.

The text of the above message is probably not exact, but the file name is.

The result of locate is shown below:

[root@fc5t3 etc]# locate check-cdrom.sh
/lib/udev/check-cdrom.sh
/mnt/fc4/etc/udev/scripts/check-cdrom.sh

It looks to my untrained mind that the script is in a different place in FC5
than it was in FC4 and that the FC4 location is being referenced in the startup.

I will restore my system to use the file that previously worked.

Let me know if I can help further.

Thanks.
Comment 18 Harald Hoyer 2006-02-24 02:14:26 EST
id=125085 was wrong, please use id=125086
Comment 19 Gerry Tool 2006-02-24 08:30:33 EST
I'm sorry for misunderstanding which was the correct file.  However, id=125086
does not work either.  The zip drive continues to thrash.  I double checked that
I had the right file this time after the test by downloading it again, both from
Comment #16 and from the Attachment list and doing a diff between those and the
file I had installed in /etc/udev/rules.d/.

I'm restoring my system to the file that worked which was id=125011.

Thanks.  Gerry
Comment 20 Gerry Tool 2006-02-24 09:55:28 EST
The updates I installed this morning included udev-084-4.  The comments above
this one were made with the previous udev installed.  The new one of course
overwrote my 50-udev.rules file that worked, and the new one results in
thrashing of the zip drive.

I am writing this so you can be clear which version of udev was/is in place.

I see some boot errors having to do with other devices with this new udev, that
were also reported in fedora-test-list. Someone there reported:

"Reverting to previous version udev-084-1.1 fixes that (messages
disappear and kde works again).

Fabio"

I will leave 084-4 installed until I hear which version you want installed for
further zip drive testing.

Thanks.
Gerry
Comment 21 Gerry Tool 2006-02-25 10:05:05 EST
I updated udev this morning.
[root@fc5t3 ~]# rpm -q udev
udev-084-6
The zip drive still thrashes forever until I overwrite the 50-udev.rules file
with the one with id=125011.  Startup is then normal and the zip drive mounts
using the GUI Computer icon interface.
Comment 22 Harald Hoyer 2006-03-01 03:36:51 EST
Created attachment 125450 [details]
50-udev.rules

Please try this one. Thx for your patience.
Comment 23 Gerry Tool 2006-03-01 08:24:16 EST
Attachment id=125450 works great. No thrashing, and the zip disk mounts from the
Computer icon applet just fine.  Thanks for your persistence.
Comment 24 Harald Hoyer 2006-03-02 02:47:36 EST
Please test ftp://people/harald/udev/084-10/
Comment 25 Gerry Tool 2006-03-02 08:38:57 EST
The zip drive works fine on boot after upgrading to 084-10.  I had to scramble a
bit to find the real URL of ftp://people.redhat.com/harald/udev/084-10/ because
it has been a while since I have seen a reference to people.redhat.com and
couldn't remember the correct URL right away.

Thanks.