Bug 1811099

Summary: SELinux is preventing ModemManager from using the setsched access on a process
Product: [Fedora] Fedora Reporter: Paul Whalen <pwhalen>
Component: selinux-policyAssignee: Zdenek Pytela <zpytela>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 32CC: dwalsh, grepl.miroslav, lvrabec, plautrba, vmojzis, zpytela
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-03-06 16:22:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Whalen 2020-03-06 15:36:44 UTC
Description of problem:
After fresh install of Fedora Server (Fedora-32-20200306.n.0 compose)

SELinux is preventing ModemManager from using the setsched access on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that ModemManager should be allowed setsched access on processes labeled modemmanager_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'ModemManager' --raw | audit2allow -M my-ModemManager
# semodule -X 300 -i my-ModemManager.pp


Additional Information:
Source Context                system_u:system_r:modemmanager_t:s0
Target Context                system_u:system_r:modemmanager_t:s0
Target Objects                Unknown [ process ]
Source                        ModemManager
Source Path                   ModemManager
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.5-28.fc32.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              5.6.0-0.rc3.git0.1.fc32.aarch64 #1 SMP Mon Feb 24
                              21:17:09 UTC 2020 aarch64 aarch64
Alert Count                   1
First Seen                    2020-03-06 10:22:16 EST
Last Seen                     2020-03-06 10:22:16 EST
Local ID                      c49dbc7d-44cd-48e2-9872-fdba6a3b9225

Raw Audit Messages
type=AVC msg=audit(1583508136.643:131): avc:  denied  { setsched } for  pid=1156 comm="ModemManager" scontext=system_u:system_r:modemmanager_t:s0 tcontext=system_u:system_r:modemmanager_t:s0 tclass=process permissive=0


Hash: ModemManager,modemmanager_t,modemmanager_t,process,setsched

Comment 1 Zdenek Pytela 2020-03-06 15:45:48 UTC
Paul,

Thank you for reporting the issue. This AVC will be dontaudited in the next version of the selinux-policy package. Apart from the denial reported, do you also see any functionality issue?

Comment 2 Paul Whalen 2020-03-06 16:02:08 UTC


Thanks, no functionality issues so far. 

I saw a few more right after install, if you would like I can open separate bugs.

Listed below:

time->Fri Mar  6 10:22:17 2020
type=AVC msg=audit(1583508137.943:147): avc:  denied  { sys_nice } for  pid=1189 comm="pcscd" capability=23  scontext=system_u:system_r:pcscd_t:s0 tcontext=system_u:system_r:pcscd_t:s0 tclass=capability permissive=0
----
time->Fri Mar  6 10:22:17 2020
type=AVC msg=audit(1583508137.943:148): avc:  denied  { setsched } for  pid=1189 comm="pcscd" scontext=system_u:system_r:pcscd_t:s0 tcontext=system_u:system_r:pcscd_t:s0 tclass=process permissive=0
----
time->Fri Mar  6 10:25:41 2020
type=AVC msg=audit(1583508341.455:221): avc:  denied  { setsched } for  pid=1412 comm="cockpit-ws" scontext=system_u:system_r:cockpit_ws_t:s0 tcontext=system_u:system_r:cockpit_ws_t:s0 tclass=process permissive=0
(In reply to Zdenek Pytela from comment #1)

Comment 3 Zdenek Pytela 2020-03-06 16:22:54 UTC
Paul,

No need to create bugzillas for the setsched permission unless you see an issue with the software. With the update the denials will no longer be audited.

Closing this bz as duplicate of bz#1795524, you can find additional information there if interested.

*** This bug has been marked as a duplicate of bug 1795524 ***