Bug 18112

Summary: amanda-client is missing the /etc/xinetd.d/amanda file
Product: [Retired] Red Hat Linux Reporter: Gilbert E. Detillieux <gedetil>
Component: amandaAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: heckmann, tibbs
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-10-02 16:20:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gilbert E. Detillieux 2000-10-02 13:05:12 EDT
# rpm -qilp redhat-7.0/i386/en/RedHat/RPMS/amanda-2.4.1p1-18.i386.rpm
|fgrep inet
/etc/xinetd.d/amandaidx
# rpm -qilp
redhat-7.0/i386/en/RedHat/RPMS/amanda-client-2.4.1p1-18.i386.rpm |fgrep
inet
# rpm -qilp
/redhat-7.0/i386/en/RedHat/RPMS/amanda-server-2.4.1p1-18.i386.rpm |fgrep
inet
/etc/xinetd.d/amandaidx
/etc/xinetd.d/amidxtape
#

For some reason, the base amanda package has an amandaidx, which is
presumably a duplicate of the one that's in amanda-server, where it rightly
belongs. However, there doesn't appear to be an /etc/xinetd.d/amanda file
at all, which would presumably belong in the amanda-client package.

The amanda SRPM seems to include all 3 xinetd files, so I assume the SPEC
file is wrong.

(This bug should be assigned the component name "amanda", but it's not in
the list.)
Comment 1 Trond Eivind Glomsrxd 2000-10-02 16:20:08 EDT
Ok, it's now possible to assign bugs to amanda. Thanks for that report. I'll
assign the bug to the amanda packager.
Comment 2 Jeff Johnson 2000-10-12 14:58:27 EDT
/etc/xinetd.d/amanda added to the amanda-server package in
amanda-2.4.2-0.19991216beta1.1.
Comment 3 heckmann 2000-10-13 11:34:00 EDT
I haven't actually looked at the new amanda package in rawhide, since the
mirrors don't have it yet, but 
/etc/xinetd.d/amanda should be added to the amanda-client package not the
amanda-server package,
the server package should have /etc/xinetd.d/amandaidx and 
/etc/xinetd.d/amidxtape.
Comment 4 bradley 2000-12-17 11:31:49 EST
The rawhide packages have not been fixed.
The amanda entry for xinetd is still in the server package when it needs to be
in the client package
Comment 5 Seth Vidal 2001-01-02 16:26:36 EST
I would have to agree with the last poster
rawhide is still not fixed
eventhough this seems silly the below is the one line patch to correct it in the
rawhide version:

--- amanda.spec~	Thu Oct 12 16:42:34 2000
+++ amanda.spec	Tue Jan  2 13:30:17 2001
@@ -178,7 +178,6 @@
 %defattr(-,root,root)
 %doc examples docs/[A-LN-Z]* docs/MULTITAPE COPYRIGHT* NEWS README SNAPSHOT
 %{_libdir}/libamserver*.so
-%config(noreplace) /etc/xinetd.d/amanda
 %config(noreplace) /etc/xinetd.d/amidxtape
 %attr(-,operator,disk)	%{_libexecdir}/amindexd
 %attr(-,operator,disk)	%{_libexecdir}/amlogroll
@@ -247,6 +246,7 @@
 %files client
 %defattr(-,root,root)
 %{_libdir}/libamclient*.so
+%config(noreplace) /etc/xinetd.d/amanda
 %attr(-,operator,disk)	%{_libexecdir}/amandad
 %attr(4750,root,disk)	%{_libexecdir}/calcsize
 %attr(4750,root,disk)	%{_libexecdir}/killpgrp