Bug 1813199

Summary: wrong shebangs in some perl tests
Product: Red Hat Software Collections Reporter: Martin Kyral <mkyral>
Component: perlAssignee: perl-maint-list
Status: CLOSED ERRATA QA Contact: Martin Kyral <mkyral>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rh-perl530CC: ppisar
Target Milestone: alphaKeywords: EasyFix, Triaged
Target Release: 3.5   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rh-perl530-perl-5.30.1-452.el7 Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-26 09:25:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin Kyral 2020-03-13 08:42:16 UTC
Description of problem:
File '/opt/rh/rh-perl530/root/usr/libexec/perl5-tests/perl-tests/t/porting/dual-life.t' has wrong interpreter '#!/perl -w' 
File '/opt/rh/rh-perl530/root/usr/libexec/perl5-tests/perl-tests/t/porting/exec-bit.t' has wrong interpreter '#!/perl -w' 
File '/opt/rh/rh-perl530/root/usr/libexec/perl5-tests/perl-tests/t/porting/test_bootstrap.t' has wrong interpreter '#!/perl -w' 


Version-Release number of selected component (if applicable):
rh-perl530-perl-5.30.1-451.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Petr Pisar 2020-03-13 11:43:46 UTC
Indeed. I can easily fix it. Nevertheless the files are not executable and thus the shebang has no meaning.

Comment 9 errata-xmlrpc 2020-05-26 09:25:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2259