Bug 1813336

Summary: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-Test-Inter-1.09/examples/*' has wrong interpreter '#!/usr/bin/perl'
Product: Red Hat Software Collections Reporter: Martin Kyral <mkyral>
Component: perlAssignee: perl-maint-list
Status: CLOSED ERRATA QA Contact: Martin Kyral <mkyral>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rh-perl530CC: ppisar
Target Milestone: betaKeywords: EasyFix
Target Release: 3.5   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rh-perl530-perl-Test-Inter-1.09-5.el7 Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-26 09:25:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin Kyral 2020-03-13 14:39:06 UTC
Description of problem:
:: [ 10:24:45 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-Test-Inter-1.09/examples/is' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:45 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-Test-Inter-1.09/examples/ok' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:45 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-Test-Inter-1.09/examples/plan' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:45 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-Test-Inter-1.09/examples/tests' has wrong interpreter '#!/usr/bin/perl' 
:: [ 10:24:46 ] :: [   FAIL   ] :: File '/opt/rh/rh-perl530/root/usr/share/doc/rh-perl530-perl-Test-Inter-1.09/examples/use_ok' has wrong interpreter '#!/usr/bin/perl' 

Generally, all the scripts shipped in a collection shall have shebangs pointing to the collection or using env.

Version-Release number of selected component (if applicable):
rh-perl530-perl-Test-Inter-1.09-4.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info: proper component (perl-Test-Inter) was mising from BZ under the RHSCL product at the moment of filing this bug. I added it in the bugzilla-components repo. To be reassigned once the data get synced with BZ.

Comment 2 Petr Pisar 2020-03-17 11:28:45 UTC
I confirm this issue. I will correct the shebangs.

Comment 8 errata-xmlrpc 2020-05-26 09:25:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2259