Bug 1813429

Summary: tests image requires /etc/passwd be writable
Product: OpenShift Container Platform Reporter: Clayton Coleman <ccoleman>
Component: Test InfrastructureAssignee: Clayton Coleman <ccoleman>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.4CC: skuznets
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1813428 Environment:
Last Closed: 2020-05-15 00:24:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1813428    
Bug Blocks:    

Description Clayton Coleman 2020-03-13 19:11:44 UTC
+++ This bug was initially created as a clone of Bug #1813428 +++

https://bugzilla.redhat.com/show_bug.cgi?id=1793287 removed the writable /etc/passwd which is required by the test infra.  I am reverting the change and back porting to 4.4 because this blocks our disruptive testing.

The underlying issue is not a cve, it is trivial for any container launcher to gain control of /etc/passwd.  The tests image is intended for a wide range of uses and this use is deliberate until we have moved all test infra to a 4.x version.

Comment 4 Steve Kuznetsov 2020-05-15 00:24:13 UTC
This merged but is not something QE verifies.