Bug 1814020

Summary: Local watchdog may not be uploading /var/log/messages
Product: [Retired] Restraint Reporter: Carol Bouchard <cbouchar>
Component: generalAssignee: Carol Bouchard <cbouchar>
Status: CLOSED NOTABUG QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 0.1.44CC: asavkov, bpeck, breilly, cbeer
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-06-02 12:07:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Carol Bouchard 2020-03-16 18:51:30 UTC
Description of problem:
While evaluating and running local watchdog tests, I see it wants to upload the file /var/log/messages file but I didn't see this happening in my test.  This is an important file as stderr/stdout of restraintd go to this file.  The logic for this seems to overlop with journalctl in 20_sysinfo.  Neither seems to be working.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
At this time this was noticed, I was working on tests to remove rhts from restraint installs.
1. Spawn a job using harness="restraint" and it does not include "restraint-rhts or beakerlib".
2. Objective of 1: You do not want rhts on the installed system.
3. Then force a job to expire due to local watchdog.

Actual results:


Expected results:


Additional info:

Comment 1 Carol Bouchard 2020-06-02 12:07:40 UTC
Closing this BZ as I've learned from recent testing, I've discovered when journalctl exists the output from this tool is presented; otherwise, it gets it from /var/log/messages (older RHEL release).