Bug 1814283

Summary: [4.4] HPA based on cpu utilization fails for pods which have init containers
Product: OpenShift Container Platform Reporter: Ryan Phillips <rphillips>
Component: NodeAssignee: Ryan Phillips <rphillips>
Status: CLOSED ERRATA QA Contact: Weinan Liu <weinliu>
Severity: medium Docs Contact:
Priority: high    
Version: 4.3.0CC: alegrand, anpicker, ansverma, aos-bugs, apaladug, btomlins, clasohm, dtarabor, erooth, jmalde, joelsmith, jokerman, kakkoyun, lcosic, mburke, mloibl, mpatel, mtleilia, pkrupa, rphillips, schoudha, suchaudh, surbania, tmckay
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: HPA was not receiving metrics from exited initcontainers. Consequence: Fix: Result: The patch correctly submits 'zero' based metrics for exited initContainers so that HPA can perform analysis on these pods.
Story Points: ---
Clone Of: 1749468 Environment:
Last Closed: 2020-05-04 11:46:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1749468    
Bug Blocks: 1822955    

Comment 6 errata-xmlrpc 2020-05-04 11:46:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581