Bug 1814463

Summary: Please provide EPEL 8 build
Product: [Fedora] Fedora EPEL Reporter: Pavel Raiskup <praiskup>
Component: dist-gitAssignee: clime7
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel8CC: asamalik, bennie.joubert, clime7, jkadlcik, msuchy, pingou, praiskup
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dist-git-1.14-1.fc32 dist-git-1.14-1.fc31 dist-git-1.14-1.el7 dist-git-1.14-1.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-30 01:53:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Pavel Raiskup 2020-03-17 23:51:33 UTC
ssia

Comment 1 clime7 2020-03-18 05:28:52 UTC
I can look at this if nobody is faster.

Comment 2 Pavel Raiskup 2020-03-18 08:16:00 UTC
Yeah, if you can, please do.  I tried yesterday, but the request
was refused [1] so I filled this bug.  Bodhi update is needed
as well.

[1] https://pagure.io/releng/fedora-scm-requests/issue/23224

Comment 3 clime7 2020-03-20 23:53:07 UTC
I took this because I already invested quite some time into it. Currently, this is a problem: https://bugzilla.redhat.com/show_bug.cgi?id=1815695

Comment 4 Pavel Raiskup 2020-03-23 10:15:56 UTC
Can you please at least build the package for now?  Even if it doesn't work,
the `dist-git-selinux` package should be installable and that's what I actually
need now on el8.

Comment 5 clime7 2020-03-23 10:46:08 UTC
(In reply to Pavel Raiskup from comment #4)
> Can you please at least build the package for now?  Even if it doesn't work,
> the `dist-git-selinux` package should be installable and that's what I
> actually
> need now on el8.

Hello!

Yes, the build is here: https://koji.fedoraproject.org/koji/buildinfo?buildID=1479084

but I didn't create an update because the package is not installable at the moment and we need to decide what to do with fedmsg.

Can you, please, update https://github.com/release-engineering/dist-git/issues/28?

But even if we fix that I can't create update just for dist-git-selinux - they would need to come from different srpms.

COPR build wouldn't be enough for the time being?

Comment 6 Pavel Raiskup 2020-03-23 11:15:53 UTC
> but I didn't create an update because the package is not installable at
> the moment and we need to decide what to do with fedmsg.

Drop the dependency.  Current fedmsg is going to be
shut-down;  and I'm not sure who plans to host it -- so I have absolutely
no motivation to beat the dead horse.  Fedora-messaging is way to go.

If you think it seriously and you want to add compat for both fedmsg and
fedora-messaging, please make it Suggests now and be fast with the compat
fixes.

We will probably have to look at this problem very soon anyways - and the
only capacity we will be to migrate to fedora-messaging (or drop the
messaging support, depending how important that thing is).  We would
probably do this long time before, but we didn't notice the dep.

> but I didn't create an update because the package is not installable at the
> moment and we need to decide what to do with fedmsg.

Update is crucial.  I need the package in repository to be able to actually
setup ansible scripts for our backups.

> COPR build wouldn't be enough for the time being?

I installed manually for now.... but still.

Comment 7 Pierre-YvesChibon 2020-05-20 15:02:15 UTC
So we're starting to look at upgrading dist-git to RHEL8 and it would be nice to have dist-git on epel8 for this :)

I'm already in the middle of the rebuild of src.stg when I discovered this and we're hoping to do prod when we rebuild the host in the new data-center, so we may want to prioritize this.

Let me know if I can help on this

Comment 8 clime7 2020-05-20 15:05:05 UTC
I am going to release a new version today, also for epel8 :).

Comment 9 Pierre-YvesChibon 2020-05-20 15:48:55 UTC
Thanks :)

Comment 10 clime7 2020-05-21 07:15:07 UTC
There were some unexpected test failures when building in koji. I am going to try to resolve them asap.

https://kojipkgs.fedoraproject.org//work/tasks/7444/44757444/build.log

Comment 11 Fedora Update System 2020-05-21 09:36:44 UTC
FEDORA-EPEL-2020-e192e5ac3f has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e192e5ac3f

Comment 12 Fedora Update System 2020-05-21 09:36:45 UTC
FEDORA-2020-97d7c83ed1 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-97d7c83ed1

Comment 13 Fedora Update System 2020-05-21 09:36:46 UTC
FEDORA-2020-bd067d0b75 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-bd067d0b75

Comment 14 Fedora Update System 2020-05-21 09:36:48 UTC
FEDORA-EPEL-2020-e3c6b00a4d has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e3c6b00a4d

Comment 15 Fedora Update System 2020-05-22 03:02:14 UTC
FEDORA-2020-bd067d0b75 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-bd067d0b75`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-bd067d0b75

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2020-05-22 04:23:54 UTC
FEDORA-2020-97d7c83ed1 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-97d7c83ed1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-97d7c83ed1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2020-05-22 05:33:44 UTC
FEDORA-EPEL-2020-e192e5ac3f has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e192e5ac3f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2020-05-22 05:45:56 UTC
FEDORA-EPEL-2020-e3c6b00a4d has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e3c6b00a4d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2020-05-30 01:53:59 UTC
FEDORA-2020-97d7c83ed1 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2020-05-30 03:51:11 UTC
FEDORA-2020-bd067d0b75 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2020-06-07 18:43:28 UTC
FEDORA-EPEL-2020-e3c6b00a4d has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 22 Fedora Update System 2020-06-08 00:44:52 UTC
FEDORA-EPEL-2020-e192e5ac3f has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.