Bug 1814593

Summary: [OSP] Installer fails to destroy cluster when cloud doesn't have trunk port support
Product: OpenShift Container Platform Reporter: Martin André <m.andre>
Component: InstallerAssignee: Martin André <m.andre>
Installer sub component: OpenShift on OpenStack QA Contact: David Sanz <dsanzmor>
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: medium CC: pprinett
Version: 4.4   
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: OpenStack clouds without trunk ports support return an error when trying to list trunk ports that was wrongly interpreted by the installer as a failure to destroy the ports. Consequence: On clouds without support for trunk ports, the destroy command would loop over trunk port deletion until it reaches the timeout. Fix: Correctly interpret the error returned when listing trunk port. Result: The destroy command returns on clouds without support for trunk ports before reaching the timeout.
Story Points: ---
Clone Of:
: 1820153 (view as bug list) Environment:
Last Closed: 2020-07-13 17:22:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1820153    

Description Martin André 2020-03-18 10:46:13 UTC
When running the `destroy cluster` command to delete a cluster deployed on a cloud without support for trunk ports, the installer fails to destroy this cluster, looping over:

DEBUG Deleting openstack trunks
ERROR Resource not found
DEBUG Exiting deleting openstack trunks


❯ openstack network trunk list
The resource could not be found.
Neutron server returns request_ids: ['req-ed792dc5-8f0d-42f7-a592-2eb6a01ae91d']

We should detect support for trunk ports and stop retrying the trunks if there is no support for it.

Comment 3 David Sanz 2020-04-02 13:06:18 UTC
Verified on 4.5.0-0.nightly-2020-04-02-085743

Comment 5 errata-xmlrpc 2020-07-13 17:22:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409