Bug 1818944

Summary: Wrong key for selecting nodes in MachineConfigPool
Product: OpenShift Container Platform Reporter: bpeterse
Component: Management ConsoleAssignee: David Taylor <dtaylor>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: aos-bugs, bpeterse, hasha, jokerman, jonjacks, rdomnu, sgoodwin, spadgett, yapei
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Compute -> Machine Config Pools -> "Create Machine Config Pool". Consequence: The template used has a 'spec.machineSelector' key for selecting the nodes to match, this key is not recognize by the API. The GUI will display a Machine Selector which seem to work correctly but the MachineConfigPool doesn't match any nodes Fix: Changed key in template to "spec.nodeSelector". Result: The GUI displays a Machine Selector which now matches nodes.
Story Points: ---
Clone Of: 1813369 Environment:
Last Closed: 2020-05-13 22:01:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1813369    
Bug Blocks:    

Comment 3 Yadan Pei 2020-04-13 06:32:41 UTC
fix is not merged in 4.4.0-0.nightly-2020-04-09-220855, will check when there is new 4.4 rc/nightly build

Comment 4 shahan 2020-04-15 03:50:28 UTC
Checked on OCP 4.4 cluster with payload 4.4.0-0.nightly-2020-04-14-222426 
1. Go to "Compute" -> "Machine Config Pools" page, click into "master" mcp, check the yaml, there is 
"  nodeSelector:
    matchLabels:
      node-role.kubernetes.io/master: ''
"
And on the detail page, the Node Selector field shows "node-role.kubernetes.io/master".
2. Create mcp with default example yaml, there is also nodeselector in the yaml template:
  nodeSelector:
    matchLabels:
      node-role.kubernetes.io/master: ''
 After create with default yaml, the "Node Selector" field shows "node-role.kubernetes.io/master", click on it, will go to search page with related nodes filtered out.
The bug is fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2020-05-13 22:01:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581