Bug 1820343

Summary: kube-scheduler should be able to log at level 10
Product: OpenShift Container Platform Reporter: Mike Dame <mdame>
Component: kube-schedulerAssignee: Mike Dame <mdame>
Status: CLOSED ERRATA QA Contact: RamaKasturi <knarra>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.4CC: aos-bugs, mfojtik
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1820344 (view as bug list) Environment:
Last Closed: 2020-05-04 11:48:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1820344    
Bug Blocks:    

Description Mike Dame 2020-04-02 19:38:05 UTC
Currently, setting `LogLevel` in the kube-scheduler to `TraceAll` only sets the kube-scheduler's loglevel (--v flag) to 8 (see [1]).

Since many of the scheduler's logs are at level 10 (such as scoring[2]), it would be much more helpful if the operator could configure 10 for TraceAll instead of 8


[1] https://github.com/openshift/cluster-kube-scheduler-operator/blob/01caed9c867a7f8fa87ac15b3bdf9335d98ef21e/pkg/operator/target_config_reconciler_v410_00.go#L144
[2] https://github.com/kubernetes/kubernetes/blob/master/pkg/scheduler/core/generic_scheduler.go#L650-L654

Comment 7 errata-xmlrpc 2020-05-04 11:48:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581