Bug 1820568 (CVE-2019-18853)

Summary: CVE-2019-18853 ImageMagick: XML_PARSE_HUGE not properly restricted in coders/svg.c
Product: [Other] Security Response Reporter: Dhananjay Arunesh <darunesh>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: fedora, jhorak, mike, pahan
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: ImageMagick 7.0.9-0, ImageMagick 6.9.10-69 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-10-28 09:47:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1820588, 1820589, 1824487    
Bug Blocks: 1824074    

Description Dhananjay Arunesh 2020-04-03 11:06:13 UTC
A vulnerability was found in ImageMagick before 7.0.9-0 allows remote attackers to cause a denial of service because XML_PARSE_HUGE is not properly restricted in coders/svg.c, related to SVG and libxml2.

Reference:
https://github.com/ImageMagick/ImageMagick/commit/ec9c8944af2bfc65c697ca44f93a727a99b405f1

Comment 1 Dhananjay Arunesh 2020-04-03 12:27:34 UTC
Created ImageMagick tracking bugs for this issue:

Affects: epel-8 [bug 1820589]
Affects: fedora-all [bug 1820588]