Bug 182092

Summary: HAL leaves user-mounted removeable media mounted after user logs off
Product: [Fedora] Fedora Reporter: William Shotts <bshotts>
Component: gnome-volume-managerAssignee: David Zeuthen <davidz>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: ivazqueznet, mclasen, triage
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: F8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-05 08:45:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description William Shotts 2006-02-20 08:29:40 EST
+++ This bug was initially created as a clone of Bug #182056 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210
Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
If a user attaches a USB storage device (say a pen drive) the device is
automatically mounted.  If the user then logs off, the device is not unmounted.
 I see this being a danger in that a user might assume that if he logs off,
he/she could just pull the pen drive out.

Version-Release number of selected component (if applicable):
hal-0.5.7-0.cvs20060213.1

How reproducible:
Always

Steps to Reproduce:
1. Attach a USB storage device while logged in as a user.
2. Log out
3. At the login screen press Ctl-Alt-F1 and log in as root.  Type "mount"
  

Actual Results:  Removable storage volumes remain mounted.

Expected Results:  Removable storage volumes shuld have been unmounted when the
user who mounted them logged out.

Additional info:

-- Additional comment from ivazquez@ivazquez.net on 2006-02-20 00:55 EST --
hal isn't responsible for mounting/unmounting volumes, so this bug is filed in
the wrong component. Please file a bug against gnome-volume-manager and/or
whatever KDE package handles automounting instead.

-- Additional comment from bshotts@panix.com on 2006-02-20 08:25 EST --
Refiling for component gnome-mount
Comment 1 William Shotts 2006-02-22 08:47:42 EST
*** Bug 182056 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Clasen 2007-04-01 17:50:20 EDT
David, I have the feeling this is a dupe.
Comment 3 Matthias Clasen 2007-04-17 15:00:47 EDT
Moving of FC7Target, this is a policy question that we cannot fix in time for F7.
Comment 4 Bug Zapper 2008-04-03 12:59:53 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.