Bug 1821630

Summary: Package replaces CentOS HighAvailability package and breaks awscli.
Product: [Fedora] Fedora EPEL Reporter: INVADE International Ltd. <third.line>
Component: python-s3transferAssignee: Orion Poplawski <orion>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel8CC: bperkins, gwync, igor.raits, me
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-18 03:12:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description INVADE International Ltd. 2020-04-07 09:17:06 UTC
Description of problem:

Not sure if this is a bug or working as designed.

(Note: This is for python3-s3transfer, which is not an option in the component drop down, not python-s3transfer.)

Installed the "awscli" package from the CentOS "HighAvailability" repository.

The "aws" command works.

Enabled the "epel" repository and updated all packages.

The "python3-s3transfer" package from the "HighAvailability" repository is replaced by the version from the "epel" repository.

The "aws" command fails.

Version-Release number of selected component (if applicable):

python3-s3transfer.noarch 0.1.13-1.el8 HighAvailability
python3-s3transfer.noarch 0.2.1-1.el8 epel

How reproducible:

Always

Steps to Reproduce:
1. dnf --enablerepo=HighAvailability install awscli
2. aws (works)
3. dnf install epel-release
4. dnf update
5. aws (fails)

Actual results:

aws
Traceback (most recent call last):
  File "/usr/bin/aws", line 27, in <module>
    sys.exit(main())
  File "/usr/bin/aws", line 23, in main
    return awscli.clidriver.main()
  File "/usr/lib/python3.6/site-packages/awscli/clidriver.py", line 58, in main
    driver = create_clidriver()
  File "/usr/lib/python3.6/site-packages/awscli/clidriver.py", line 69, in create_clidriver
    event_hooks=emitter)
  File "/usr/lib/python3.6/site-packages/awscli/plugin.py", line 44, in load_plugins
    modules = _import_plugins(plugin_mapping)
  File "/usr/lib/python3.6/site-packages/awscli/plugin.py", line 61, in _import_plugins
    module = __import__(path, fromlist=[module])
  File "/usr/lib/python3.6/site-packages/awscli/handlers.py", line 27, in <module>
    from awscli.customizations.cloudformation import initialize as cloudformation_init
  File "/usr/lib/python3.6/site-packages/awscli/customizations/cloudformation/__init__.py", line 13, in <module>
    from awscli.customizations.cloudformation.package import PackageCommand
  File "/usr/lib/python3.6/site-packages/awscli/customizations/cloudformation/package.py", line 26, in <module>
    from awscli.customizations.s3uploader import S3Uploader

Expected results:

aws
usage: aws [options] <command> <subcommand> [<subcommand> ...] [parameters]
To see help text, you can run:

  aws help
  aws <command> help
  aws <command> <subcommand> help
aws: error: the following arguments are required: command

Additional info:

Manually downgrading the "python3-s3transfer" package from the "HighAvailability" repository fixes the problem.

Comment 1 INVADE International Ltd. 2020-04-08 16:18:42 UTC
Just to add, it looks like another package now conflicts:
python3-botocore.noarch                                    1.9.1-2.el8                                             HighAvailability                
python3-botocore.noarch                                    1.13.21-1.el8                                           epel

dnf --enablerepo=HighAvailability update
Last metadata expiration check: 0:00:06 ago on Wed 08 Apr 2020 17:11:01 BST.
Error: 
 Problem: package awscli-1.14.50-5.el8.noarch requires python3-botocore = 1.9.1, but none of the providers can be installed
  - cannot install both python3-botocore-1.13.21-1.el8.noarch and python3-botocore-1.9.1-2.el8.noarch
  - cannot install the best update candidate for package python3-botocore-1.9.1-2.el8.noarch
  - cannot install the best update candidate for package awscli-1.14.50-5.el8.noarch
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Comment 3 Orion Poplawski 2020-04-18 03:12:02 UTC
Since RHEL8.1 HA is not a free product and EPEL cannot build against it, EPEL 8 can conflict with it.