Bug 1823822

Summary: Mate-Compiz spin installs f31 and f32 backgrounds packages
Product: [Fedora] Fedora Reporter: Wolfgang Ulbrich <fedora>
Component: mate-desktopAssignee: Wolfgang Ulbrich <fedora>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: awilliam, bcotton, fedora, sgallagh, stefano
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: mate-desktop-1.24.0-3.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-14 21:43:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1705306    

Description Wolfgang Ulbrich 2020-04-14 14:56:53 UTC
Description of problem:
Mate-Compiz spin installs f31 and f32 backgrounds packages

from current Fedora-MATE_Compiz-Live-32-1.2
https://koji.fedoraproject.org/koji/buildinfo?buildID=1493302
https://kojipkgs.fedoraproject.org//packages/Fedora-MATE_Compiz-Live/32/1.2/data/logs/image/x86_64/livemedia-out.log

2020-04-14 12:44:21,852 INFO pylorax: Verifying f31-backgrounds-base.noarch (281/1614)
2020-04-14 12:44:21,852 INFO pylorax: Verifying f31-backgrounds-mate.noarch (282/1614)
2020-04-14 12:44:21,852 INFO pylorax: Verifying f32-backgrounds-base.noarch (283/1614)
2020-04-14 12:44:21,852 INFO pylorax: Verifying f32-backgrounds-mate.noarch (284/1614)

This is caused by a typo in spec file, btw it is fixed now.
https://src.fedoraproject.org/rpms/mate-desktop/c/fad7b6754a159ab2790a4894a1c259240bce774d?branch=master

- %if 0%{?fedora} && 0%{?fedora} >= 31
+ %if 0%{?fedora} && 0%{?fedora} == 31 

Version-Release number of selected component (if applicable):
mate-desktop-1.24.0-2.fc32

How reproducible:

Take a look at latest livemedia-out.log of mate-compiz spin.

Comment 1 Fedora Blocker Bugs Application 2020-04-14 15:01:42 UTC
Proposed as a Freeze Exception for 32-final by Fedora user raveit65 using the blocker tracking app because:

 Mate-Compiz spin installs both f31 and f32-backgrounds packages.
Caused by a typo in mate-desktop spec file.
A new build of mate-desktop package can fix this easily.

Comment 2 Fedora Update System 2020-04-14 15:05:00 UTC
FEDORA-2020-237a9c594f has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-237a9c594f

Comment 3 Adam Williamson 2020-04-14 16:08:40 UTC
Sure, +1 FE. Small bug, harmless fix.

Comment 4 Stephen Gallagher 2020-04-14 16:21:52 UTC
+1 FE

It's a low-risk change and even if it goes awry, Mate is a non-blocking deliverable.

Comment 5 Fedora Update System 2020-04-14 16:50:42 UTC
FEDORA-2020-237a9c594f has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-237a9c594f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-237a9c594f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Ben Cotton 2020-04-14 16:58:39 UTC
+1 FE

Comment 7 Adam Williamson 2020-04-14 17:10:37 UTC
That's +3, accepting.

Comment 8 Fedora Update System 2020-04-14 21:43:57 UTC
FEDORA-2020-237a9c594f has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.