Bug 1825140

Summary: zypper-1.14.35-2.fc33 FTBFS: 4 - Locales_test (Failed)
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: zypperAssignee: Neal Gompa <ngompa13>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: besser82, igor.raits, ngompa13
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://koschei.fedoraproject.org/package/zypper
Whiteboard:
Fixed In Version: zypper-1.14.37-1.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-08-09 03:03:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1843119    
Bug Blocks: 1803234, 1803235    

Description Petr Pisar 2020-04-17 07:24:40 UTC
zypper-1.14.35-2.fc33 fails to build in Fedora 33 because the tests fail there:

    Start 4: Locales_test
4: Test command: /builddir/build/BUILD/zypper-1.14.35/aarch64-redhat-linux-gnu/tests/Locales_test "--catch_system_errors=no"
4: Test timeout computed to be: 10000000
4: Initializing Target
4: Target initialization failed:
4: Failed to cache rpm database (139).
4: History:
4:  - 
4: 
4: Running 'zypper refresh' as root might resolve the problem.
4: unknown location(0): fatal error: in "Test setup": ExitRequestException: Target initialization failed: Failed to cache rpm database (139).
4: Running 2 test cases...
4: 
4: [1;32;49m*** No errors detected
4: [0;39;49mTest setup error: 
4/6 Test #4: Locales_test .....................***Failed    1.18 sec
Initializing Target
Target initialization failed:
Failed to cache rpm database (139).
History:
 - 
Running 'zypper refresh' as root might resolve the problem.
unknown location(0): fatal error: in "Test setup": ExitRequestException: Target initialization failed: Failed to cache rpm database (139).

A difference between a passing and failing build root is at <https://koschei.fedoraproject.org/build/8173988>.

This could be triggered by upgrading rpm from 4.15.1-2.fc32.1 to 4.15.90-0.git14971.3.fc33 .

Comment 1 Petr Pisar 2020-06-30 12:32:14 UTC
*** Bug 1852241 has been marked as a duplicate of this bug. ***

Comment 2 Petr Pisar 2020-06-30 12:35:49 UTC
In addition, this cannot be built because libzypp has not yet been rebuilt against a new Boost.

DEBUG util.py:621:  No matches found for the following disable plugin patterns: local, spacewalk
DEBUG util.py:621:  Error: 
DEBUG util.py:621:   Problem: package libzypp-devel-17.23.2-1.fc33.x86_64 requires libzypp.so.1722()(64bit), but none of the providers can be installed
DEBUG util.py:621:    - package libzypp-devel-17.23.2-1.fc33.x86_64 requires libzypp(x86-64) = 17.23.2-1.fc33, but none of the providers can be installed
DEBUG util.py:621:    - conflicting requests
DEBUG util.py:621:    - nothing provides libboost_thread.so.1.69.0()(64bit) needed by libzypp-17.23.2-1.fc33.x86_64

Comment 3 Igor Raits 2020-07-08 09:24:57 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 4 Neal Gompa 2020-07-12 14:11:34 UTC
Working on this...

Comment 5 Neal Gompa 2020-08-09 03:03:35 UTC
Fixed with zypper-1.14.37-1.fc33 in Rawhide.