Bug 1825809

Summary: oc create build
Product: OpenShift Container Platform Reporter: Maciej Szulik <maszulik>
Component: ocAssignee: Maciej Szulik <maszulik>
Status: CLOSED ERRATA QA Contact: wewang <wewang>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.5CC: aos-bugs, jokerman, mfojtik
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-13 17:28:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Maciej Szulik 2020-04-20 10:19:20 UTC
oc is missing the ability to create a bare minimum build.

Comment 3 wewang 2020-04-24 10:44:45 UTC
Verified in version:
$ ./oc version
Client Version: 4.5.0-0.nightly-2020-04-21-103613

Steps:
$ ./oc create build test-build --dockerfile-contents $'FROM centos:7\nRUN true' --to-image-stream=wewang/test:latest
build.build.openshift.io/test-build created
$ oc get builds
test-build           Docker   Dockerfile    Complete   29 seconds ago       28s

Comment 4 errata-xmlrpc 2020-07-13 17:28:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409