Bug 1826488

Summary: Edit ClusterServiceVersion should not be a first class Action
Product: OpenShift Container Platform Reporter: bpeterse
Component: Management ConsoleAssignee: Robb Hamilton <rhamilto>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: low Docs Contact:
Priority: unspecified    
Version: 4.4CC: aos-bugs, dtaylor, jokerman, yanpzhan
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
: 1827306 (view as bug list) Environment:
Last Closed: 2020-07-13 17:29:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1827306    

Description bpeterse 2020-04-21 19:09:48 UTC
Original issue reported in Jira:
- https://issues.redhat.com/browse/CONSOLE-2164

Description of problem:


The ClusterServiceVersion is not a resource we generally want admins interacting with, but today when you go to Operators -> Installed Operators -> Some Operator, the Actions dropdown has Edit ClusterServiceVersion as the first available action.

We should remove this action entirely since the admin would still be able to directly edit the YAML from the YAML tab if there was a need to hack / workaround some problem.

Comment 1 bpeterse 2020-04-21 19:10:28 UTC
We may want to backport this.

Comment 5 Yanping Zhang 2020-04-24 06:38:32 UTC
Checked on 4.5 cluster with payload 4.5.0-0.nightly-2020-04-23-202137.
Install an operator from console, then check installed operators, click kebab action, there is no "Edit ClusterServiceVersion" menu now.

Comment 6 errata-xmlrpc 2020-07-13 17:29:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409