Bug 1826788

Summary: Audit daemon does not halt the system when the audit partition is full
Product: Red Hat Enterprise Linux 8 Reporter: Zdenek Pytela <zpytela>
Component: selinux-policyAssignee: Zdenek Pytela <zpytela>
Status: CLOSED ERRATA QA Contact: Milos Malik <mmalik>
Severity: medium Docs Contact: Mirek Jahoda <mjahoda>
Priority: medium    
Version: 8.2CC: fjc, jafiala, lvrabec, mjahoda, mmalik, pasik, plautrba, sgrubb, ssekidde, vmojzis
Target Milestone: rcKeywords: AutoVerified, Triaged
Target Release: 8.3   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
.SELinux no longer prevents `auditd` to halt or power off the system Previously, the SELinux policy did not contain a rule that allows the Audit daemon to start a `power_unit_file_t` `systemd` unit. Consequently, `auditd` could not halt or power off the system even when configured to do so in cases such as no space left on a logging disk partition. This update of the `selinux-policy` packages adds the missing rule, and `auditd` can now properly halt and power off the system only with SELinux in enforcing mode.
Story Points: ---
Clone Of: 1780332 Environment:
Last Closed: 2020-11-04 01:56:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1780332    
Bug Blocks:    

Comment 13 errata-xmlrpc 2020-11-04 01:56:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (selinux-policy bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4528