Bug 1826922

Summary: Openshift 4.4 Baremetal IPI install fails using external DHCP server on provisioning network
Product: OpenShift Container Platform Reporter: Stephen Benjamin <stbenjam>
Component: InstallerAssignee: Stephen Benjamin <stbenjam>
Installer sub component: OpenShift on Bare Metal IPI QA Contact: Victor Voronkov <vvoronko>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: urgent CC: augol, beth.white, ccrum, ohochman, rbartal, vvoronko, zeenix
Version: 4.4Keywords: Triaged
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1823359 Environment:
Last Closed: 2020-06-17 22:26:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1823359, 1829938    
Bug Blocks:    

Comment 1 Zeeshan Ali 2020-05-04 12:20:56 UTC
Does https://github.com/openshift/installer/pull/3504 fixes this issue (completely)? If so, the CI bot needs the status to be update here.

Comment 2 Stephen Benjamin 2020-05-04 12:25:49 UTC
The bots will update the BZ status will get updated when 4.4.z is the new default target (it's 4.4.0 until 4.4 GA), the PR is refreshed, and the valid-bug label is added.

Comment 3 Stephen Benjamin 2020-05-04 12:27:16 UTC
Looks like 4.4.z is the new target, but the 4.5 BZ needs to be QE'd. There's no need to set needinfo on me though, I have no action to take.

Comment 4 Zeeshan Ali 2020-05-06 15:16:08 UTC
> There's no need to set needinfo on me though, I have no action to take.

Right, sorry I wasn't aware of the process.

Comment 9 Victor Voronkov 2020-05-26 17:26:11 UTC
depends on another merge https://bugzilla.redhat.com/show_bug.cgi?id=1829938

Comment 20 errata-xmlrpc 2020-06-17 22:26:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2445