Bug 1830370

Summary: HAProxy Router connections are not cleaned up when closed
Product: OpenShift Container Platform Reporter: Dan Williams <dcbw>
Component: NetworkingAssignee: Ben Bennett <bbennett>
Networking sub component: ovn-kubernetes QA Contact: Siva Reddy <schituku>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: urgent CC: aos-bugs, bbennett, bperkins, ctrautma, dblack, dcbw, jiji, jishi, jtaleric, mleitner, mmichels, nusiddiq, ralongi, rkhan, rsevilla, yinxu
Version: 4.3.zKeywords: Performance, TestBlocker
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: aos-scalability-43
Fixed In Version: Doc Type: Rebase: Bug Fixes Only
Doc Text:
Important: if this rebase also contains *enhancements* (or contains only enhancements), select the correct option from the Doc Type drop-down list. Rebase package(s) to version: OVS/OVN to 2.13 Highlights and important bug fixes: Fixed TCP connection cleanup when closed.
Story Points: ---
Clone Of: 1819785
: 1830416 (view as bug list) Environment:
Last Closed: 2020-07-13 17:34:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1819785    
Bug Blocks: 1830416    

Comment 7 Dan Williams 2020-05-14 15:28:06 UTC
Back to ON_QA, mistakenly moved to POST by the PR robot.

Comment 8 Siva Reddy 2020-05-18 13:37:06 UTC
Moving to verify as the version is upgraded

oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.4.0-0.nightly-2020-05-14-234853   True        False         155m    Cluster version is 4.4.0-0.nightly-2020-05-14-234853

oc rsh -n openshift-ovn-kubernetes ovnkube-master-dfsm6 
Defaulting container name to northd.
Use 'oc describe pod/ovnkube-master-dfsm6 -n openshift-ovn-kubernetes' to see all of the containers in this pod.
sh-4.2# rpm -qa | grep ovn
ovn2.13-2.13.0-30.el7fdp.x86_64
ovn2.13-central-2.13.0-30.el7fdp.x86_64
ovn2.13-vtep-2.13.0-30.el7fdp.x86_64
ovn2.13-host-2.13.0-30.el7fdp.x86_64

Comment 9 errata-xmlrpc 2020-07-13 17:34:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409