Bug 1830472

Summary: undefined reference to `__aarch64_ldadd4_acq_rel
Product: [Fedora] Fedora Reporter: Mattias Ellert <mattias.ellert>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 32CC: anto.trande, aoliva, dmalcolm, fweimer, jakub, jwakely, law, mhroncok, mpolacek, msebor, nickc, pbrobinson, quantum.analyst, rdieter, rjones, sgehwolf, sipoyare
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gcc-10.0.1-0.14.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-07 03:10:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 245418    

Description Mattias Ellert 2020-05-02 04:29:47 UTC
Description of problem:

After gcc was updated to version 10.0.1-0.13 the build of root started failing in koschei for aarch64 with a missing symbol during linking:
https://koschei.fedoraproject.org/package/root?collection=f33

Version-Release number of selected component (if applicable):

gcc-c++-10.0.1-0.13.fc33.aarch64

How reproducible:

I triggered a second attempt in koschei and it failed the same way.

Steps to Reproduce:
1. Build root in rawhide

Actual results:

Build fails with missing symbol

Expected results:

Successful build

Additional info:

/usr/bin/ld: /usr/include/c++/10/ext/atomicity.h:50: undefined reference to `__aarch64_ldadd4_acq_rel'

Comment 1 Jakub Jelinek 2020-05-02 11:45:59 UTC
On aarch64 -moutline-atomics has been turned on by default, and those symbols are solely in libgcc.a, not in libgcc_s.so.*.
So, libgcc_s.so linker script is needed instead of libgcc_s.so symlink like on some other arches, gcc-10.0.1-0.14.fc33 with a fix is building in koji.

Comment 2 Jakub Jelinek 2020-05-03 09:08:19 UTC
Should be hopefully fixed in gcc-10.0.1-0.14.fc33.

Comment 3 Elliott Sales de Andrade 2020-05-04 05:33:03 UTC
This is also currently a problem on Fedora 32: https://koji.fedoraproject.org/koji/taskinfo?taskID=44074576 and there do not appear to be any new builds.

Comment 4 Jakub Jelinek 2020-05-04 07:05:02 UTC
Yes, because the F32 build wasn't intended to be pushed, I built it in F32 too just because some people wanted it.

Comment 5 Mattias Ellert 2020-05-05 04:39:40 UTC
Now also affects Fedora 32 with gcc-10.0.1-0.13.fc32, see e.g.:

https://koschei.fedoraproject.org/package/xrootd?collection=f32

Hovever, rawhide is no longer affected with gcc-10.0.1-0.14.fc33. see e.g.

https://koschei.fedoraproject.org/package/xrootd?collection=f33

Comment 6 Miro Hrončok 2020-05-05 17:35:57 UTC
Please, can we get the broken build untagged from Fedora 32? This is blocking other packages.

Comment 8 Fedora Update System 2020-05-05 18:23:47 UTC
FEDORA-2020-c66e53d090 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c66e53d090

Comment 9 Fedora Update System 2020-05-06 02:23:31 UTC
FEDORA-2020-c66e53d090 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c66e53d090`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c66e53d090

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-05-07 03:10:07 UTC
FEDORA-2020-c66e53d090 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.