Bug 1832094

Summary: FTI: upm: upm-devel
Product: [Fedora] Fedora Reporter: Igor Raits <igor.raits>
Component: upmAssignee: Peter Robinson <pbrobinson>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: pbrobinson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: upm-2.0.0-6.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-22 05:30:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1750909    

Description Igor Raits 2020-05-06 04:49:35 UTC
Hello,

Your package (upm) Fails To Install in Fedora 33:

---
can't install upm-devel-2.0.0-5.fc33.x86_64:
  - nothing provides pkgconfig(jpeg) needed by upm-devel-2.0.0-5.fc33.x86_64
---

According to a policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks if you won't reply to this bug.

The data was generated from koji buildroot, so it might be a bit newer than latest rawhide compose.

Thanks!

Comment 2 Peter Robinson 2020-05-13 09:30:18 UTC
Investigating, I think this was from changes Miro made due to nodejs issues due to swig not supporting newer versions of nodejs

Comment 3 Peter Robinson 2020-05-13 09:32:37 UTC
actually no, it's something around libjpeg. In the package the devel has the following requires:

Requires: libjpeg-turbo-devel

But on install I get:
# dnf install upm-devel
Last metadata expiration check: 0:30:13 ago on Wed 13 May 2020 10:00:11 BST.
Error: 
 Problem: conflicting requests
  - nothing provides pkgconfig(jpeg) needed by upm-devel-2.0.0-5.fc32.i686
  - nothing provides pkgconfig(jpeg) needed by upm-devel-2.0.0-5.fc32.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

so I have no idea why the auto build requires adds this.

Comment 4 Fedora Update System 2020-05-13 13:05:53 UTC
FEDORA-2020-e06d324248 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-e06d324248

Comment 5 Peter Robinson 2020-05-13 14:47:05 UTC
*** Bug 1834129 has been marked as a duplicate of this bug. ***

Comment 6 Igor Raits 2020-05-13 18:36:29 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain@fedoraproject.org).

All subpackages of a package agaisnt which this bug was filled are now installable or removed from Fedora 33.

Thanks for taking care of it!

Comment 7 Fedora Update System 2020-05-14 04:31:27 UTC
FEDORA-2020-e06d324248 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-e06d324248`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e06d324248

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-05-22 05:30:23 UTC
FEDORA-2020-e06d324248 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.