Bug 1834956

Summary: Find by name field content doesn't get removed even we change the page and come back
Product: OpenShift Container Platform Reporter: Rohit Rai <rorai>
Component: Dev ConsoleAssignee: Rohit Rai <rorai>
Status: CLOSED ERRATA QA Contact: Gajanan More <gamore>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.5CC: aos-bugs, nmukherj
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-13 17:37:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
validated none

Description Rohit Rai 2020-05-12 18:24:03 UTC
Description of problem:Topology text filter is saved in redux which is why the filter is applied even if user returns to topology after being redirected from an action on another page.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Scenario:
1. Find any workload on topology using Find by name field.
2. Go to +Add page
3. Create a workload

Actual Results:
The find by name field content doesn't get removed and shows the workload which was found because of Find by name field content.

Expected Results:
When user changes the page from topology page, the content of Find by name field should also get removed.

Additional Info:
Build: 4.5.0-0.ci-2020-05-09-014245
Browser: Google Chrome Version 81.0.4044.129

Comment 3 Gajanan More 2020-05-19 10:33:31 UTC
Created attachment 1689836 [details]
validated

Comment 4 Gajanan More 2020-05-19 10:34:04 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-05-18-204038
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared video
Marking this as verified

Comment 5 errata-xmlrpc 2020-07-13 17:37:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409