Bug 1835576

Summary: [ovirt] allow template parameters customization (mem/cpu/disk) in the machine
Product: OpenShift Container Platform Reporter: Roy Golan <rgolan>
Component: Cloud ComputeAssignee: Roy Golan <rgolan>
Cloud Compute sub component: oVirt Provider QA Contact: Guilherme Santos <gdeolive>
Status: CLOSED ERRATA Docs Contact:
Severity: urgent    
Priority: urgent CC: gdeolive, jzmeskal, rdlugyhe
Version: 4.4   
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1813741 Environment:
Last Closed: 2020-06-02 11:18:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1813741    
Bug Blocks: 1820300, 1830001, 1835795    

Comment 3 Jan Zmeskal 2020-05-22 12:34:20 UTC
I can verify this only indirectly via verifying https://bugzilla.redhat.com/show_bug.cgi?id=1835795

Comment 4 Guilherme Santos 2020-05-25 16:39:03 UTC
Verified on:
openshift-install-linux-4.4.0-0.nightly-2020-05-24-133612

Steps:
1. created a config file: # openshift-install create --dir install_files/ install_config
2. edited the install-config.yaml setting the following variables with non-default value (XX)
(...)
controlPlane/compute:
  name: master/worker
  platform:
    ovirt:
      cpu:
        cores: XX
        sockets: XX
      memoryMB: XX
      osDisk:
        sizeGB: XX
      vmType: high_performance
(...)
platform:
  ovirt:
    api_vip: <ip>
    dns_vip: <ip>
    ingress_vip: <ip>
    ovirt_cluster_id: <id>
    ovirt_storage_domain_id: <id>
    ovirt_network_name: ovirtmgmt
    vnicProfileID: <id>
(...)

3. # openshift-install create --dir install_files/ cluster
4. on UI, checked the created machines properties

Results:
installation successfully finished and non-default properties set on yaml file present on vms

Comment 6 errata-xmlrpc 2020-06-02 11:18:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310